0

I have the following minimal example:

\documentclass{article}

\usepackage[bookmarks=true]{hyperref}

\begin{document}

\tableofcontents

\section{Background}

Here is some Background.

\section{System}

This is the system under study.

\section{Results}

\subsection{Result 1}

We got some results.

\subsection{Result 2}

And then some more results.

\end{document}

I run it through pdflatex twice so that the .aux file will be correct. However, when I open the PDF, it has no bookmarks at all.

I did notice that the .out file was generated, and appears to be correct as far as I can tell:

\BOOKMARK [1][-]{section.1}{Background}{}% 1
\BOOKMARK [1][-]{section.2}{System}{}% 2
\BOOKMARK [1][-]{section.3}{Results}{}% 3
\BOOKMARK [2][-]{subsection.3.1}{Result 1}{section.3}% 4
\BOOKMARK [2][-]{subsection.3.2}{Result 2}{section.3}% 5

So, why don't these bookmarks show up in the PDF?

I've looked at several other SE questions regarding bookmarks, but none of them have helped resolve the issue.

Thanks for your help.

  • 2
    welcome to tex.sx. sorry to say, i can't reproduce your problem -- the bookmarks are present when i look at the output using adobe reader, and they link to the requested locations. very puzzling. – barbara beeton Oct 17 '17 at 15:19
  • That makes sense. The latex is so simple it's hard to imagine what could be wrong with it. Is it possibly a bug of some kind in my pdflatex installation? I don't get any error message, so I don't know where to start trying to investigate that kind of issue. – Captain Numerical Oct 17 '17 at 15:34
  • maybe it's the pdf reader you're using. what is it? also, in adobe reader, there is a small icon that allows one to "disappear" the bookmarks. it's probably an option that can be preset. you might consider that possibility too. – barbara beeton Oct 17 '17 at 16:02
  • Oh, man! That is indeed the issue. I'm using "Document Viewer" under linux, and the bookmarks appear under "Index" rather than "Bookmarks". Thanks for your help! – Captain Numerical Oct 17 '17 at 16:30
2

It turns out this was an issue with my PDF viewer, as noted in the comments above. Many thanks to barbara beeton for pointing me in that direction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.