1

Given the file hello.tex which is simply

\documentclass{article}
\begin{document}
    Hello world!
\end{document}

which is located in C:\Users\jonat\Desktop\Test, I run the following commands from my command line and get the following error messages

C:\Users\jonat\Desktop\Test
>>pdftex hello.tex
This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017/W32TeX) (preloaded format=pdftex)
 restricted \write18 enabled.
entering extended mode
! I can't write on file `hello.log'.
(Press Enter to retry, or Control-Z to exit; default file extension is `.log')
Please type another transcript file name:

C:\Users\jonat\Desktop\Test
>>pdflatex hello.tex
This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017/W32TeX) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
! I can't write on file `hello.log'.
(Press Enter to retry, or Control-Z to exit; default file extension is `.log')
Please type another transcript file name:

C:\Users\jonat\Desktop\Test
>>latexmk hello.tex
Latexmk: This is Latexmk, John Collins, 19 Jan. 2017, version: 4.52c.
Cannot write file 'hello.aux'
C:\texlive\2017\bin\win32\runscript.tlu:708: command failed with exit code 13:
perl.exe c:\texlive\2017\texmf-dist\scripts\latexmk\latexmk.pl hello.tex

In order to troubleshoot this problem I have done the following:

  1. Reinstalled TexLive distribution.
  2. Restarted my computer.
  3. Checked that I have read and write permissions for this folder.

I am at a loss for why I am getting these errors. Any help would be much appreciated.

  • either you do not have write access to that directory or some process is holding the files open and locking write access. try a new file in a new directory – David Carlisle Oct 20 '17 at 20:39
  • Ok, i just checked my antivirus Bitdefender and learned that it keeps blocking access. Ok now i need to figure out how to stop that. – Jonathan Davidson Oct 20 '17 at 20:45
  • 1
    You asked the same thing yesterday and I told you to look at tex.stackexchange.com/questions/393420/… – Ulrike Fischer Oct 20 '17 at 21:15
1

I have experienced the same problem. It vanished after I removed the folder ~/.texmf-var.

I found this option here .

UPD: I have also tried the second option from this forum and deleted ~/.texlive folder. It was a terrible idea, TexLive stopped working at all. So I needed to reinstall everything.

|improve this answer|||||
  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – Vincent Feb 13 at 20:39
  • Thanks for your feedback, I forgot about such issues – Daryna Ivaskevych Feb 14 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.