2

I am currently using the correction proposed on this discussion for adjusting space when french quotation marks are used.

It works fine until I used also biblatex. Biblatex does not seem to use the right quotation mark (add a space after the opening quotation mark and add one before the closing quotation mark).

Since a csquotes command is used the quotation marks are well positionned as expected form the other question.

In the reference (in the bibliography or when a \cite command is used the spaces are not well defined especially for the opening quotation mark.

MWE:

\documentclass{article} 
\listfiles
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@ARTICLE{article,
  author = {Nachname, Vorname},
  title = {Titel des Zeitschriftenartikels},
  journal = {Zeitschrift},
  year = {2006},
  volume = {6},
  pages = {19--75}
}
@BOOK{book,
  author = {Buchautor, Hans-Wilhelm},
  title = {Irgendein Buch},
  address = {Buch am Wald},
  year = {2000}
}
\end{filecontents}

\RequirePackage{polyglossia}  
\setmainlanguage{french}
\setotherlanguage{german}
\setotherlanguage{english}

\usepackage[autostyle=true,debug=true,autopunct=true,csdisplay=false]{csquotes} 
\makeatletter \XeTeXinterchartoks 4095 \french@punctguillend = {\xpg@unskip\nobreakspace}

%bibliographie
\usepackage[
bibstyle=verbose,
citestyle=verbose-ibid,
autocite=footnote, 
language=french]{biblatex}
\bibliography{\jobname}


\begin{document}

\hyphenblockquote{french}{aha ahh vazdbazofbazpofna ofna foinao}

\cite{book}
\cite{article}
\autocite{article}

\printbibliography

\end{document}

Result: result

2

You need a similar settings for the begin quote sign. But I would use babel instead of polyglossia. There it works out-of-the box and the french-module of babel is well maintained. Also the output is better: with the polyglossia work-around the spacing is too large. Or use lualatex which give better output too.

\documentclass{article}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@ARTICLE{article,
  author = {Nachname, Vorname},
  title = {Titel des Zeitschriftenartikels},
  journal = {Zeitschrift},
  year = {2006},
  volume = {6},
  pages = {19--75}
}
@BOOK{book,
  author = {Buchautor, Hans-Wilhelm},
  title = {Irgendein Buch},
  address = {Buch am Wald},
  year = {2000}
}
\end{filecontents}

\RequirePackage{polyglossia}
\setmainlanguage{french}
\setotherlanguage{german}
\setotherlanguage{english}

\usepackage[autostyle=true,debug=true,autopunct=true,csdisplay=false]{csquotes}

\makeatletter
  \XeTeXinterchartoks \french@punctguillstart 4095 = {\nobreakspace\xpg@nospace}% "«  " -> "«~"
  \XeTeXinterchartoks 4095 \french@punctguillend = {\xpg@unskip\nobreakspace}
\makeatother

%bibliographie
\usepackage[
bibstyle=verbose,
citestyle=verbose-ibid,
autocite=footnote,
language=french]{biblatex}
\bibliography{\jobname}


\begin{document}

\hyphenblockquote{french}{aha ahh vazdbazofbazpofna ofna foinao}

\cite{book}
\cite{article}
\autocite{article}

\printbibliography

\end{document}

enter image description here

Output with babel and xelatex:

enter image description here

Output with polyglossia and lualatex

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.