2

This question already has an answer here:

Background:

I was working on a LaTeX document but getting errors about 'newtxtext.sty' and 'newtxmath.sty'(similar to what's described here, although that solution didn't work)

That led me down the path of updating texlive. After many forum searches, I followed instructions here:

sudo add-apt-repository ppa:jonathonf/texlive
sudo apt update && sudo apt install texlive-full

This led to texmaker not being able to start with an error similar to that described here. This led me to find that the jonathonf/texlive repo and subsequent texlive-full install had actually installed Tex 2018 which seemed to be too far ahead for texmaker.

I thought I would try again with the normal texlive installation, so I followed instructions here to remove the jonathonf/texlive ppa, and then instructions here to do a clean install of texlive.

This led me back to square one. Now I knew to look for the TeX version to find out that it had installed 2015! apt-get update, and upgrade did not seem to have any effect. Trying to mess with tlmgr for updates as described here only led to errors about "Unknown directive" as described here


Question

Therefore my question is, what is the the most stable, recent version of texlive (2016 or 2017, because 2018 doesn't work for me)? Furthermore, how do you install it?

  • This blog post indicates that I use a similar approach as I was before but instead add the ppa jonathonf/texlive-2016. This seems like a very obscure way to just get the most stable version of tex.
  • Another obvious approach would be to follow these instructions. It's not super obvious where you actually get the install-tl script (I think I eventually found it), and it seems bizarre that there is not an apt-get approach for Linux.

Thanks!

marked as duplicate by Loop Space, Troy, CarLaTeX, Stefan Pinnow, Phelype Oleinik Mar 12 '18 at 21:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    Welcome to TeX.SE! Have you considered installing vanilla texlive instead? tex.stackexchange.com/questions/1092/… – hpesoj626 Oct 26 '17 at 1:55
  • If you could use Jonathon's PPA, you probably use 16.04. The PPA has only TL 2016 and 2017. The directions for installing vanilla TL are accurate and they work, but they get beyond basic use and maintenance. If you like apt, you might consider upgrading to 17.10. BTW, apt is only one of many package managers out there. You can also get the latest packages that you need from CTAN, install them in your home user ~/texmf tree, then execute texhash ~/texmf, if that's in your comfort zone. – Charles P. Schaum Oct 28 '17 at 6:31
1

Sister page Askubuntu has a related quesstion: https://askubuntu.com/questions/927346/install-texlive-2017-on-ubuntu-16-04-lts

If you follow the instructions to add the PPA like in the question, you can install texlive 2017. I recommend to remove all parts from 2015 (or 2016) before to avoid package conflicts.

Not the answer you're looking for? Browse other questions tagged or ask your own question.