0

I had this problem a week or two ago and I posted here but nothing from the suggested solutions seemed to work. I have managed to get some more details on it, in case anyone can help me, because this issue is causing me huge productivity problems and I really want it solved.

So I'm using Linux mint distribution, and I've installed Lyx via the software manager. Every time that I open a new document, I get an error claiming that some files are missing, and until they are installed, compiling the files or exporting them as pdfs is not possible. The file in question is called "extarticle.cls". Additionally, under Document->Settings->Document Class, every document class is marked as unavailable.

Here is the thing though.. this file is not missing... I have located it inside a folder associated with Lyx. It's definitely not missing.

I really need help with this one guys... It's been weeks since the problem came up and I really just want to be rid of it.. Why does this thing not work? Any help?

  • Did you installed texlive as mentioned in the comments of your previous question? – koleygr Oct 29 '17 at 17:12
  • I did. In fact, I even tried uninstalling all packages I had, then installing them again. Nothing changed. – Harry K. Oct 29 '17 at 17:21
  • What was the command you gave to install texlive? – koleygr Oct 29 '17 at 17:24
  • I installed it from the software manager. The package was named "texlive-all", with the description: "Tex live: metapackage pulling in all components of tex live". Was that a mistake? Should I have done it via the terminal? – Harry K. Oct 29 '17 at 17:35
  • 1
    Do you want to tell me what exactly worked to make it an answer available for future users too? I mean that I need to know if the field there was empty and what you wrote there to make it work... (You are welcome) – koleygr Oct 29 '17 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.