0

After re-installation of MikTex (I had troubles of pdflatex.exe not found at startup of TexStudio), I am now trying to reinstall my packages for my documents.

I am promted to install the first package encountered in my TexStudio script (natbib): TexStudio asks for:

enter image description here

It asks to install the package from my selected repository: http://vesta.informatik.rwth-aachen.de/ftp/pub/mirror/ctan/systems/win32/miktex/tm/packages/

But when I select to install it (and MikTex installer gets launced), TexStudio gives the error:

enter image description here

So I tried open the MikTex package manager (both the non- and Admin version), searching for natbib, and installing it. However then I get the error:

The remote package repository is outdated. You have to choose another repository.

Now, I have tried several repositories, and I always get prompted with the same error?

I don't know if this could be the cause, but daylight-saving just changed in belgium, which seemed to be a problem last year?

I keep being told the remote package repository is outdated

I also had a similar issue myself earlier:

titlesec.sty not found

Back then, I could solve it by doing a synchronize on the repository. However, again I'm prompted with:

The remote package repository is outdated. You have to choose another repository.

Would appreciate all help.

  • Welcome to TeX SX! I've tested a few other repositories and have the same problem. A problem with the servers? You try the following work-around: download via ftp the packages you want to install to a directory on hard hard disk, plus pr.ini, files.csv.lzma, miktex-zzb1-2.9.tar.lzma, miktex-zzb2-2.9.tar.lzma and ask to download from this directory. – Bernard Oct 30 '17 at 13:34
  • Thank you for your response, the files you are referring to: pr.ini, files.csv.lzma, miktex-zzb1-2.9.tar.lzma, miktex-zzb2-2.9.tar.lzma where can they be found? – MaartenVL Oct 30 '17 at 13:51
  • Oh! yes Sorry for the mistyping. – Bernard Oct 30 '17 at 13:52
  • The error is a passing problem with the server. See github.com/MiKTeX/miktex/issues/27. – Ulrike Fischer Oct 30 '17 at 13:54
  • @UlrikeFischer - It is working again now indeed, seemed to be server related! – MaartenVL Oct 31 '17 at 8:17
1

The problem resolved itself this morning, apparently the last CTAN update failed, quoting developer and maintainer of MiKTeX, Christian Schenk:

"I am afraid that all repositories are currently out-of-date because the last CTAN upload was unsuccessful. The next CTAN upload is scheduled, ETA is 20171031T0600 (UTC)."

https://github.com/MiKTeX/miktex/issues/27#issuecomment-340549770

  • The "one of the tech guys" you are quoting is the developer and maintainer of MiKTeX, Christian Schenk. – Ulrike Fischer Oct 31 '17 at 8:59
  • edited, sorry for the ignorance. – MaartenVL Nov 1 '17 at 9:51
0

I had the same problem with packages. When the package installation opens, don't directly click Install. First change the option "The package will be installed for: 1) Anyone who uses this computer(all users) or 2) your user

Select your user (second) and the package will install. In my case, the problem was the user permission for miktex to be able to install on Windows 10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.