0

I upgraded my local MikTeX installation to version MiKTeX 2.9.6500 and all packages via MikTex Update app on Windows 10. The idea is to use now latest release of biblatex 3.7.

However, when I compile my document using \listfiles in the preamble, I can see that version 3.4 is used.

biblatex.sty 2016/05/14 v3.4 programmable bibliographies (PK/JW/AB)

blx-compat.def 2016/05/14 v3.4 biblatex compatibility (PK/JW/AB)

blx-bibtex.def 2016/05/14 v3.4 biblatex compatibility (PK/JW/AB)

biblatex.def 2016/05/14 v3.4 biblatex compatibility (PK/JW/AB)

standard.bbx 2016/05/14 v3.4 biblatex bibliography style (PK/JW/AB)

authoryear.bbx 2016/05/14 v3.4 biblatex bibliography style (PK/JW/AB)

The authoryear style offered by biblatex standard is a prerequisite for my own bbx style file. I am using pdftex, bibtex8 as bibliography backend and packages for german localization.

Why is still version 3.4 used? How can I check if version 3.7 is correctly installed?

  • 1
    What does kpsewhich biblatex.sty say when you type it into the command line? You can also check the path where the files are found in the .log file. Did you run the Updater both in admin and user mode (i.e., did you run 'Update (Admin)' and 'Update')? – moewe Oct 31 '17 at 19:09
  • 1
    I have had serious trouble when mixing MikTeX Update and MikTeX Update (Admin). Which mode do you use? I would recommend to remove all packages from the user installation and make sure that you install everything in Admin mode. – Matthias Oct 31 '17 at 22:33
  • @Matthias: It is for miktex users not so easy to avoid that something is installed as user but normally this is not a problem as long as you always run the update manager in both modes. – Ulrike Fischer Nov 1 '17 at 11:08
  • @Ulrike I use MikTeX along with TeXnicCenter. I have switched off the install-packages-on-the-fly option. Whenever LaTeX complains about a missing package, I enter cmd as Admin and install the package manually using mpm --admin --install=<package>. This way I have kept a clean installation for quite some time. – Matthias Nov 1 '17 at 11:28
  • @Matthias well as I said: not so easy. You need to know that on-the-fly can interfere, you need to know how to find the miktex name of a missing package, you need to know how to open a cmd as admin. For the standard user it is easier to either install as single-user (but you must know this at installation time ...) or to call the update manager in both modes. – Ulrike Fischer Nov 1 '17 at 11:37
0

Based on the comment of Matthias, I could solve the topic on my own. I did a complete refresh of my MikTeX 2.9 software on my machine. During the installation wizard I chose the option to install the software only for me instead of anyone/all users.

Advantages:

  • There is only one folder for binary files and packages located in the AppData folder of the user directory.
  • There is only one application "MikTeX Update" for package updates.
  • I can call MikTeX via TexnicCenter without entering admin password.

Disadvantage: In contrast to Windows standard, binary program files are not located within directory C:\Program Files.

Finally, my installation makes use of latest biblatex version 3.7.

  • 3
    This will probably also work. I use the opposite approach. MikTeX is installed for anyone/all users, but I never install a package in user mode. I achieve this by switching off the install-packages-on-the-fly option. Whenever LaTeX complains about a missing package, I enter Admin mode and install it manually. This way everything is located in C:\Program Files. The solution proposed by Ulrike to always update in user and admin mode is also possible, however, results in duplicate packages. – Matthias Nov 1 '17 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.