I've been using Latex for almost 2,5 years now. Since i installed Windows 10 on my Laptop, TeXmaker wont work. The most common error, that its shows is:

This is pdfTeX, Version 3.1415926-2.5-1.40.14 (MiKTeX 2.9 64-bit) (preloaded format=pdflatex 2015.3.5) 6 MAR 2015 20:54 entering extended mode

I get this message for this code:



\title{Ein Testdokument} 
\author{Otto Normalverbraucher} 
\date{5. Januar 2004} 


 Hier kommt die Einleitung. Ihre Überschrift kommt 
 automatisch in das Inhaltsverzeichnis. 


 \LaTeX{} ist auch ohne Formeln sehr nützlich und 
  einfach zu verwenden. Grafiken, Tabellen, 
  Querverweise aller Art, Literatur- und 
  Stichwortverzeichnis sind kein Problem. 

  Formeln sind etwas schwieriger, dennoch hier ein 
  einfaches Beispiel.  Zwei von Einsteins 
  berühmtesten Formeln lauten: 
  E &= mc^2                                  \\ 
  m &= \frac{m_0}{\sqrt{1-\frac{v^2}{c^2}}} 
  Aber wer keine Formeln schreibt, braucht sich 
  damit auch nicht zu beschäftigen. 

I hope one can help me. Next Projects are incoming....^^


  • 2
    Did you recreate the formats as I told you? Nov 1, 2017 at 20:04
  • 3
    you have not shown any error message just the normal startup banner (although for a two year old latex) Nov 1, 2017 at 20:20
  • FWIW, your test file compiles just fine on a MacBookPro, MacOSX 10.13 "High Sierra", MacTeX2017, pdfTeX 3.14159265-2.6-1.40.18, and LaTeX2e format <2017-04-15>. Looks like you should update both pdfTeX and LaTeX2e.
    – Mico
    Nov 1, 2017 at 21:19

2 Answers 2


It works fine for me in the same configuration (windows 10, texmaker, MiKTeK 2.9 64 bit)

Update yours packages with MiKTeK Update (admin)

enter image description here

Your format is a bit old (preloaded format=pdflatex 2015.3.5)

So build your format with MiKTeK Settings (admin). Il you compile with latex, choose latex and then build. Il you compile with pdflatex, choose pdflatex and build. And so on ..

enter image description here

You can alternatively Updates all the formats in one command with Updates Formats on the General tab

enter image description here

  • Thank you for your advice. I tried to update it,the way u showed it on your pic. but a error occurred : Sorry, but something went wrong: Windows API error 127: Die angegebene Prozedur wurde nicht gefunden. (means the given procedure was not found) dllName="C:\Program Files\MikTeX2.9\miktex/bin/x64\MiKTeX2009-packagemanager.dll"
    – CAKO
    Nov 1, 2017 at 21:57
  • Maybe you have tried to do it when another instance of the Update manager or of the MiKTeX settings was opened. Close everything. You can even restart a new fresh session or even restart the computer to be sure and try again.
    – Idefix
    Nov 1, 2017 at 22:05
  • nope same error :(
    – CAKO
    Nov 1, 2017 at 22:22
  • Then try to use the non admin version of the Update manager (close the other one), and if you have it click Ok to repair
    – Idefix
    Nov 1, 2017 at 22:24
  • next error(non admin): Sorry, but something went wrong: The executed process did not succeed. fileName="C:\Program Files\MiKTeX 2.9\miktex\bin\x64\initexmf.exe",exitCode="1" Ohhh gosh :(
    – CAKO
    Nov 1, 2017 at 22:32

Surprise Surprise: Solved it: I deleted everything that included Miktex and Texmaker and installed Miktex again. Updated it, made sure that there is no other update. Ok. Texmaker installed. Still not working. Looked inside of Texmaker Configuration and in PDFLATEX there was this order: -shell-escape=external which i deleted and surprisingly it works now. I did not had it in the beginning until i compared my config with a friend and added it. Puhhhhhhh Finally it works!!! Update - Configuration check!

  • Congratulations. You may need the -shell-escape (without =external) option when for instance you compile some pdftricks code with pdflatex. But it allows access to command system by tex source when they are compiled (by the \write18 tex command). So this is security breach which should not be used permanently just when it is necessary because of the packages you use.
    – Idefix
    Nov 4, 2017 at 20:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .