1

I just installed Texmaker 5.0.2 for Ubuntu MATE 17.10 and the icons are unbearably large in the interface (see screenshots), even the configuration window takes up the whole screen.

I think my problem is the following - I have an ASUS ZenBook UX303LN, which comes with a QHD 3200x1800 screen, and guessing by this post, Texmaker is trying to adjust for that. However, the screen has been replaced since a I bought it with a lower resolution 1920x1080 screen, and I'm guessing that's the reason the icons appear too large.

I've tried to remove all the toolbars I can, but still the buttons are huge and the spacing by the line numbers is too large. The configuration window doesn't seem to have options to change this. Any suggestions for a fix?

enter image description here

enter image description here

5
  • The sibling of texmaker, texstudio has adjustable icon size. Commented Nov 2, 2017 at 14:01
  • @samcarter thanks, will look into it, though I'm used to Texmaker and would like to keep using it. Commented Nov 2, 2017 at 14:03
  • Attaching another monitor (also 1920x1080) makes all the icons appear absurdly small, when the editor window is moved to that screen. I really liked that Texmaker split the source and PDF into two windows, but TeXstudio has as well. Am switching to TeXstudio now. Commented Nov 2, 2017 at 15:16
  • Welcome to texstudio :) I also switched from texmaker to it a few years ago and never regretted it. Commented Nov 2, 2017 at 15:17
  • Duplicate of tex.stackexchange.com/questions/454353/…
    – user170109
    Commented Apr 1, 2019 at 19:27

1 Answer 1

1

The problem is not with Texmaker but with QT which at least in my machine (Linux Mate 18.04.2) is not properly set up.

I fixed it by setting QT_SCALING_FACTOR=1. Texmaker works beautifully with my UHD monitor now.

In my case, I do this in the command line, but you can set that variable somewhere else I guess:

$ QT_SCALE_FACTOR=1 texmaker

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .