0

This question already has an answer here:

When i'm trying to execute this code:

\documentclass[a4paper, 12pt]{article}

\usepackage{filecontents}

\begin{filecontents*}{trial.bib}
    @article{paper,
    author={name},
    title="{title}",
    journal={J. Phys. Conf. Ser.},
    volume={67},
    number={},
    pages={23},
    year={2007}
}
\end{filecontents*}

\begin{document}
\title{Autumn Term Report}
\author{myself}
\date{\today}
\maketitle

HI \cite{paper}

\bibliographystyle{unsrt}
\bibliography{trial}
\end{document}

I get the following:

enter image description here

I can not understand why my BibTex does not work. I'm using TeXstudio and tried to execute that by XeLaTeX and PdfLaTeX compilers.

Thanks in advance!

marked as duplicate by Mensch, Troy, CarLaTeX, TeXnician, egreg bibtex Nov 3 '17 at 7:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did you explicitly run bibtex? In addition to pdflatex/xelatex – Dai Bowen Nov 2 '17 at 21:43
  • 2
    Does this answer help you? Question mark instead of citation number – gusbrs Nov 2 '17 at 21:46
  • @DaiBowen, no, i just put this line in the settings of IDE. – Alexander Zolkin Nov 2 '17 at 21:48
  • 2
    Bibtex is a separate tool which must be run independently to latex . In order to get citations working it is necessary to run (pdf/xe)latex bibtex (pdf/xe)latex (pdf/xe)latex – Dai Bowen Nov 2 '17 at 21:50
  • This sequence of commands described by DaiBowen is probably set in TeXStudio's "Build & View" command. But they can also be independently accessed through the "Tools" menu. – gusbrs Nov 2 '17 at 21:53
0

Thanks to you all, i just did not used to compile bibliography separately. F8 before compilation is helped (or Tools->Bibliography).

Not the answer you're looking for? Browse other questions tagged or ask your own question.