Hoefler Text Pro when put under Style = Historic will load the long S in, but it is not contextual. It will show up even at the end of words

I've also tried every single Contextual feature available in Fontspec's documentation, no luck so far. Anyway here's the code I'm having issues with


\usepackage{fontspec, xltxtra}

\setmainfont[Style = Historic, Contextuals = {WordInitial, Alternate}]{Hoefler Text Pro}


sometimes st ct ff ffi ffj fj


The Hoefler Text Pro I have is version 1.201

1 Answer 1


I solved this by editing the font itself and adding the following:

feature hist { # Historical Forms
    sub s' [a-z A-Z] by longs;
    sub Q by Q.alt;

 script latn; # Latin

    sub s' [a-z A-Z] by longs;
    sub Q by Q.alt;

 language TRK ; # Turkish
} hist;

just made sure every S followed by any letter gets substituted to longs so that final longs is not a thing, I also made one for 2 adjacent long s getting substituted by germandbls as some old texts had some sort of ligature between the first long s to a simple looking s after it. Thanks whoever read my question.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .