1

I am trying to run arara on a Windows 10 (x64) system from MikTeX 2.9 as follows in this MWE:

% arara: pdflatex
\documentclass{article}

\begin{document}
Hello world.
\end{document}

What I get is the following error message:

arara.exe: MikTeX encountered an internal error.
arara.exe: Data: index="4294967295"

arara is installed in my system, and I have checked it is in the system's path by issuing the "arara" command from the command line to an affiramtive response: the arara introduction message is displayed in the command line window.

Any hints to solve this issue will be welcome.

  • I might need to investigate, I suspect it's something related to the MiKTeX wrapper around arara rather than the Java binary itself. Quick Q: was it working before? – Paulo Cereda Nov 3 '17 at 17:09
  • what happens when you run pdflatex yourfile on the command line? Did you install arara with the miktex package manager? – Ulrike Fischer Nov 3 '17 at 17:19
  • @Paulo Cereda: I first tried it in an earlier MikTeX version on Windows XP and it worked fine. That was a few years back when arara was first issued. I didn't try it again until today. – Marcos Nov 3 '17 at 17:21
  • @Ulrike Fischer: It works perfectly. Both from the command line and from WinEdt (8.0). And, yes, I installed (and reinstalled today, just in case) arara with the MikTeX package manager. – Marcos Nov 3 '17 at 17:22
  • @Marcos: back to the drawing board. :) Does other tool like latexmk work? Perhaps if MiKTeX had an option to reinstall the "package", it could fix things that possibly got messed up... – Paulo Cereda Nov 3 '17 at 17:24
1

The problem has been resolved by an update. So I'm writing a more general answer:

internal error indicates a bug. And so the first step to handle this is to check if everything is up-to-date. This means check with both update managers (admin and user) for updates. If there are lot of updates open it is senseful to open the package manager (admin), synchronize and to check if they are uninstalled packages starting with miktex before actually getting the updates.

If the problem persists after the update you can make a bug report at https://github.com/MiKTeX/miktex/issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.