2

maybe I am just a clod, but really I cannot make the bibliography to be in the author-year style with TextPad. It always deliver the same numeric style. This is my code (sorry if there is alot stuf that does not matter, but I am not sure if there is some inconsistency with other portions of the code):

\documentclass[12pt,a4paper]{article}
\usepackage[T1]{fontenc}
\usepackage[english]{babel}
\usepackage[autostyle,italian=guillemets]{csquotes}
\usepackage[backend=biber]{biblatex}
\usepackage[style=authoryear-comp]{biblatex}

\addbibresource{bibliography.bib}

\begin{document}

\cite[5]{Dowe:1996}\\
\\
\cite{Dummett:2004}
\printbibliography
\end{document}

And instead of an authoryear bibliography I get this:

enter image description here

What can I do in order to obtain something like "Dowe (1996)", without the square brackets and with the normal brackets? And what can I do in order to have a author-year bibliography instead that a numeric one?

Thank you in advance!

2

In the first place, you should not load biblatex twice, as you do. You should load it once, with all the options.

So, like:

\usepackage[backend=biber,style=authoryear-comp]{biblatex}

I can suppose that, as your code goes, biblatex is loaded in the first call with the default numeric style, and then the second call, when you try to set the style to authoryear-comp, is likely ignored (it does give you an "option clash for biblatex" error, though). Anyway, current versions of biblatex have biber as default backend, you don't need to specify it, so you could simply use:

\usepackage[style=authoryear-comp]{biblatex}

Furthermore, to get citations in the format you mentioned, you should use \textcite.

Summing up:

\documentclass[12pt,a4paper]{article}
\usepackage[T1]{fontenc}
\usepackage[english]{babel}
\usepackage[autostyle,italian=guillemets]{csquotes}
\usepackage[style=authoryear-comp]{biblatex}

\addbibresource{biblatex-examples.bib}

\begin{document}

\textcite{kastenholz}

\textcite{sarfraz}

\printbibliography
\end{document}

Which, once you run (pdf)latex -> biber -> (pdf)latex, will render:

enter image description here

  • yes now it works, also with simple \cite command :) thank you very much – Lorenzo Nov 4 '17 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.