0

I'm using the textpos package with Beamer in order to put some text at the bottom right corner of a slide. Despite having read the package instructions, I fail to understand how to set the text height of the textblock. The relative instructions say:

There is an alternative, starred, form of the {textblock} environment. In the argument to the {textblock*} environment, the block width, and the block position (but not the specification of the block reference point) are given as absolute dimensions, rather than as numbers in units of the horizontal and vertical modules. Thus

\begin{textblock*}{hhsizei}[hhoi,hvoi](hhposi,hvposi)
text...
\end{textblock*}

produces a textblock of the given size, where this time hhsizei, hhposi and hvposi are absolute dimensions, but hhoi and hvoi are still pure-number offsets (that is, fractions of the width and height of the textblock), as above.

Each {textblock} environment takes up zero space on the page (which means, by the way, that it cannot detect that it’s overprinting or being overprinted), so you can (and typically will) use several of the environments in a row to scatter text all over the page.

The package is compatible with the calc package, so that you may use calc-style expressions when specifying lengths. Thus

\usepackage{calc}
\textblockorigin{56.9055pt-10mm}{0pt+1cm}
\begin{textblock*}{10mm+14cm}(0.3cm*5,10\TPVertModule+5mm)
6
text. . .
\end{textblock*}

Note that you can only use calc-style expressions where you would specify a length with units, such as the width and location arguments of {textblock*} or the arguments to \textblockorigin – you can’t use them when specifying a length in units of the horizontal and vertical modules, such as in the width and location arguments to the (unstarred) {textblock} environment.

However, I have to admit I don't fully understand these instructions. I would like thte text in the textblock to be a bit smaller than the normal text.

Here is a mwe:

    \documentclass[17pt,t]{beamer}
\usetheme{default}

\usepackage{graphicx}

\setbeameroption{hide notes}
\setbeamertemplate{note page}[plain]

\beamertemplatenavigationsymbolsempty
\hypersetup{pdfpagemode=UseNone}

\useoutertheme{miniframes}

\usepackage[absolute,overlay]{textpos}
\newcommand\FrameText[1]{%
  \begin{textblock*}{\paperwidth}(0pt,\textheight)
    \raggedleft #1\hspace{.5em}
  \end{textblock*}}

\begin{document}
\begin{frame}[c]{Plops}
Plops plops plops
\FrameText{Textblock}
\end{frame}

\end{document}

Thanks a lot for your help!

  • 1
    I think this might be a beamer question rather than a textpos one (since I dimly remember that the font-size commands work a little unexpectedly in beamer), but changing #1 to {\tiny #1} seems to work for me. – Norman Gray Nov 5 '17 at 21:39
1

I have somewhat solved the problem by adding a size tag on an individual \FramText (but I know there is a way to generalize the text size in the settings of \newcommand\FrameText) :

\documentclass[17pt,t]{beamer}
\usetheme{default}

\usepackage{graphicx}

\setbeameroption{hide notes}
\setbeamertemplate{note page}[plain]

\beamertemplatenavigationsymbolsempty
\hypersetup{pdfpagemode=UseNone}

\useoutertheme{miniframes}

\usepackage[absolute,overlay]{textpos}
\newcommand\FrameText[1]{%
  \begin{textblock*}{\paperwidth}(0pt,\textheight)
    \raggedleft #1\hspace{.5em}
  \end{textblock*}}

\begin{document}
\begin{frame}[c]{Plops}
Plops plops plops
\FrameText{\footnotesize Textblock}
\end{frame}

\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.