7

Today I just ran TeX Live Utility (on a Mac computer), and one of the updated packages was biblatex. Now when I tried to run biber, I got this error:

INFO - This is Biber 2.7
INFO - Logfile is 'drafter.blg'
INFO - Reading 'drafter.bcf'
ERROR - Error: Found biblatex control file version 3.4, expected version 3.3.
This means that your biber (2.7) and biblatex (3.8) versions are incompatible.
See compat matrix in biblatex or biber PDF documentation.
INFO - ERRORS: 1

But Tex Live Utility says there are no new updates. I tried manually replacing the biber file in the directory /usr/local/texlive/2017/bin/x86_64-darwin with the biber version 2.8 downloaded from sourceforge, but this leads biber to return further errors:

Can't load '/var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/79628e8f.bundle' for module XML::LibXML: dlopen(/var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/79628e8f.bundle, 1): Library not loaded: /opt/local/lib/libxml2.2.dylib
  Referenced from: /var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T//par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/79628e8f.bundle
  Reason: Incompatible library version: 79628e8f.bundle requires version 12.0.0 or later, but libxml2.2.dylib provides version 10.0.0 at /loader/HASH(0x1010521e0)/DynaLoader.pm line 197.
 at /loader/HASH(0x10180d3f8)/PAR/Heavy.pm line 123.
BEGIN failed--compilation aborted at /var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/inc/lib/XML/LibXML.pm line 156.
Compilation failed in require at /var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/inc/lib/XML/LibXML/Simple.pm line 17.
BEGIN failed--compilation aborted at /var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/inc/lib/XML/LibXML/Simple.pm line 17.
Compilation failed in require at /var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/inc/lib/Biber/LaTeX/Recode.pm line 16.
BEGIN failed--compilation aborted at /var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/inc/lib/Biber/LaTeX/Recode.pm line 16.
Compilation failed in require at /var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/inc/lib/Biber/Utils.pm line 19.
BEGIN failed--compilation aborted at /var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/inc/lib/Biber/Utils.pm line 19.
Compilation failed in require at /var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/inc/lib/Biber/Internals.pm line 8.
BEGIN failed--compilation aborted at /var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/inc/lib/Biber/Internals.pm line 8.
Compilation failed in require at /loader/HASH(0x101052d20)/parent.pm line 16.
BEGIN failed--compilation aborted at /var/folders/sv/81s9w58d08l025xt8kcf964h0000gn/T/par-616c6578616e647265/cache-1ee9314aaa3260adaf3551aacd2069b05422a0ef/inc/lib/Biber.pm line 5.
Compilation failed in require at script/biber-darwin line 17.
BEGIN failed--compilation aborted at script/biber-darwin line 17.

How can I fix this problem?

4
  • 6
    there was a problem in uploading biblatex/biber to CTAN. You have to revert to biblatex 3.3 and wait until biber is updated, too.
    – user2478
    Nov 5, 2017 at 18:39
  • 2
    There seems to be a problem with the latest macOS Biber binaries: github.com/plk/biber/issues/187
    – dbmrq
    Nov 5, 2017 at 21:45
  • 4
    Sorry about this - there are some unexpected issues with releasing biber to TL currently, due to library packaging problems for OSX. Hope to have this fixed soon.
    – PLK
    Nov 6, 2017 at 16:47
  • 3
    The biber issue on OSX is now solved and I will release again shortly and update here. It was an issue with the packaging module and the author pf that module helped to find a solution.
    – PLK
    Nov 8, 2017 at 15:57

2 Answers 2

2

I had exactly the same problem over here (Win7-64, TexLive 2017, updated yesterday).

Today, the invocation of tlmgr update --list reported an update for biblatex:

C:\Windows\system32>tlmgr update --all
tlmgr.pl: package repository http://ftp.cvut.cz/tex-archive/systems/texlive/tlnet (not verified: gpg
 unavailable)
tlmgr.pl: saving backups to D:/texlive/2017/tlpkg/backups
[ 1/12, ??:??/??:??] update: biblatex [7011k] (45690 -> 45702) ... done

... also 11 more packages, I removed from this answer ... 

running mktexlsr ...
done running mktexlsr.
running mtxrun --generate ...
done running mtxrun --generate.
regenerating fmtutil.cnf in D:/texlive/2017/texmf-dist
running fmtutil-sys --no-error-if-no-engine=luajittex,mfluajit --byfmt platex ...
done running fmtutil-sys --no-error-if-no-engine=luajittex,mfluajit --byfmt platex.
running fmtutil-sys --no-error-if-no-engine=luajittex,mfluajit --byfmt uplatex ...
done running fmtutil-sys --no-error-if-no-engine=luajittex,mfluajit --byfmt uplatex.
tlmgr.pl: package log updated: D:/texlive/2017/texmf-var/web2c/tlmgr.log

and this update solved the problem. Thanks for the question and thanks to Herbert for his comment.

2
3

This should be fixed now - please get biber 2.8 from Sourceforge again.

1
  • 1
    Isn't this more of a comment?
    – TeXnician
    Nov 8, 2017 at 20:35

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .