2

Because of my research interests, my documents are usually filled to the brim with examples in a language that needs to be glossed. For some reason, a lot of my expex glossed examples are split at page break leaving the translation line separate from the other gloss lines, as so:

   Line in the foreign language.
   line with word-per-word glosses

   ------- page break---------

   'Line with the translation.'

This is set in the following way:

\ex
\begingl
\gla Line in the foreign language //
\glb line with word-per-word glosses //
\glft `Line with the translation.'//
\endgl
\xe

The expex documentation suggests using \par\nobreak, but that only works between \a examples, not between gloss lines.

I'm sure I'm not the only one that has come against this problem, but I haven't been able to find discussions about it. Any solutions out there?

---Edit: A screencap example

enter image description here

  • have you tried wrapping the group with \begin{samepage} ... \end{samepage}? – Bordaigorl Nov 8 '17 at 17:00
  • I didn't think of trying this. Still, while it doesn't give an error, it makes no difference: oi63.tinypic.com/flkgsl.jpg – Bernat Bardagil Nov 9 '17 at 13:05
  • 1
    Unless you provide an MWE (a compilable document showing the issue) it's very unlikely we will be able to help. The issue may be caused by packages you loaded, options or custom macros etc. – Bordaigorl Nov 9 '17 at 19:04
  • Also, you may try playing with the aboveglftskip. Have you tried with samepage enclosing the whole \ex...\xe expression? – Bordaigorl Nov 9 '17 at 19:15
  • You could put each gloss and translation in a parbox. – AML Apr 18 '18 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.