1

I am writing a thesis which is almost ready and includes the setspace package like this; \usepackage{setspace} For TOC and references is use singlespacing and onehalfspacing for the rest. However, I found a rather strange (to me) behavior and it seems to be related to the DIV option in KOMA classes. But only with my non-standard font.

Even if I state \onehalfspacing right at the beginning of the document, the result differs if I also call setspace like this: \usapackage[onehalfspacing]{setspace}

Please see the MWE and enable the onehalfpacing option of setspace:

\documentclass[DIV=13,parskip=half]{scrreprt}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[english]{babel}

\usepackage{newtxtext,newtxmath}

\usepackage{blindtext}
\usepackage[
%onehalfspacing
]{setspace}

\begin{document}

\onehalfspacing
\chapter{Introduction}
\Blindtext

\end{document}
2

There is nothing strange. If you use option parskip in the document preamble, the \parskip value is set depending in the \baselineskip value while \begin{document}. \baselineskip depends on whether or not you load setspace with or without option onehalfspacing or using a command like \onehalfspacing in the document preamble. So \parskip is different with or without commenting out the option.

Other packages, that are loaded after setspace and use \baselineskip for the initial value of a length will also produce different results.

For KOMA-Script you can change the behaviour of parskip using option parskip=relative:

\documentclass[DIV=13,parskip=half,parskip=relative]{scrreprt}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[english]{babel}

\usepackage{newtxtext,newtxmath}

\usepackage{blindtext}
\usepackage[
%onehalfspacing
]{setspace}

\begin{document}

\onehalfspacing
\verb|\parskip|=\the\parskip

\chapter{Introduction}
\Blindtext

\end{document}

But AFAIK their are warnings about using this option at least in the German KOMA-Script book. You can also refresh option parskip after changing \baselineskip:

\documentclass[DIV=13,parskip=half]{scrreprt}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[english]{babel}

\usepackage{newtxtext,newtxmath}

\usepackage{blindtext}
\usepackage[
onehalfspacing
]{setspace}

\begin{document}

\onehalfspacing
\KOMAoptions{parskip=half}
\verb|\parskip|=\the\parskip

\chapter{Introduction}
\Blindtext

\end{document}

BTW: The KOMA-Script manual has some additional information about using setspace, e.g., because of changes to the vertical position of headings of ToC, LoF etc. and because of recalculation of the text area and the margins.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.