I have just installed LyX on my Laptop.

I tried to edit an existing .lyx document I had and then I tried to save it. I am getting the following error: "The document could not be saved. Do you want to rename the document and try again?"

enter image description here

When trying to rename and save in the same location I get the following error:

enter image description here

More information:

  1. I'm running windows 10

  2. I tried to run LyX as administrator but those errors stay the same. The UAC is set as low as possible, and I am logged on as the administrator.

  3. The file is also not read-only.

  4. The file is in a local folder within Dropbox, which may be related to the issue. I tried exiting dropbox process but I still get the same error, clicking "Retry" also gets this error.

Any ideas?

  • Did saving with a new name help? Perhaps the file was write-protected somehow. – Torbjørn T. Nov 10 '17 at 9:20
  • 1
    Sometimes, Windows locks a document or directory because it is used or modified by another program. The reason is not always obvious. If so, a reboot will help. – user24582 Nov 10 '17 at 10:07
  • 1
    Then something blocks probably specifically .lyx files. Check if some firewall or virus protection / defender is active and overeager. Check also the content of the pathext environment variable. Check your dropbox settings. And don't run lyx as admin but with your normal user rights: admins often don't have the rights to write into user folders. – Ulrike Fischer Nov 10 '17 at 11:52
  • 1
    I've seen Windows users have this error occasionally and I've never been able to reproduce on Ubuntu. If you find the problem, please let us know. Note that LyX 2.3.0rc1 should be out soon. You could give that a try if you were very daring (but of course you should back everything up before a big change). – scottkosty Nov 10 '17 at 19:06
  • 1
    I've noticed this as well on Windows (but not Ubuntu), and it does seem to be Dropbox related. If you just pause the syncing while saving these errors never occur, and then resume syncing when done. Frustrating. – philchalmers Jul 11 '18 at 6:11

I have the same problem, I think it is caused by the way dropbox manages files on windows.

Lyx creates a new file and then tries to change its name, which under dropbox creates a conflict which cannot be resolved automatically.

I suggest working outside the dropbox folder and only move the finished files there.


As of Windows 10 (1803), the issue may also be caused by Windows Defender's optional ransomware protection, which doesn't recognize LyX as a legitimate program by default.

Note that nothing will indicate, that this feature is the cause.


For me, it helped a bit to switch of the "backup original document when saving" in LyX Tools->Settings. In LyX Version

enter image description here


I have the same problem. Strangely, this works in 95% of the time: you get the error message "The document could not be saved..." when you click on Save, so just hit ESC (i.e. don't save it under a different name), and then press Save again (i.e. under the same name) - and Lyx saves it! In the 5% of the cases it doesn't work, just do it again: ESC, Save etc... It always works eventually.

So what Lyx protests against, Lyx does do 2 seconds(!) later. A mystery... People say it must be Dropbox: but I do save other types of files into Dropbox and I only encounter with this problem in Lyx.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.