I tried to install R in my system. I ran ./configure, that results-

config.status: creating tools/Makefile
config.status: creating src/include/config.h
config.status: src/include/config.h is unchanged
config.status: executing libtool commands
config.status: executing stamp-h commands

R is now configured for x86_64-pc-linux-gnu

  Source directory:          .
  Installation directory:    /usr/local

  C compiler:                gcc -std=gnu99  -g -O2
  Fortran 77 compiler:       gfortran  -g -O2

  Default C++ compiler:      g++   -g -O2
  C++98 compiler:            g++  -g -O2
  C++11 compiler:            g++ -std=gnu++11 -g -O2
  C++14 compiler:              
  C++17 compiler:              
  Fortran 90/95 compiler:    gfortran -g -O2
  Obj-C compiler:         

  Interfaces supported:      X11
  External libraries:        readline, curl
  Additional capabilities:   PNG, JPEG, NLS
  Options enabled:           shared BLAS, R profiling

  Capabilities skipped:      TIFF, cairo, ICU
  Options not enabled:       memory profiling

  Recommended packages:      yes

configure: WARNING: pcre < 8.32 is deprecated
configure: WARNING: you cannot build info or HTML versions of the R manuals
configure: WARNING: you cannot build PDF versions of vignettes and help pages
configure: WARNING: neither inconsolata.sty nor zi4.sty found: PDF vignettes and package manuals will not be rendered optimally

Now, I need iconsolata.sty and zi4.sty for fixing the installation warnings. How to check these fonts are whether exist or not in my texlive 2017 distribution. My OS is Ubuntu 14.04.

/usr/local/texlive/2017/texmf-dist/fonts$ ls
afm  cid  cmap  enc  lig  map  misc  ofm  opentype  ovf  ovp  pk  sfd  source  tfm  truetype  type1  vf


I checked tlmgr info iconsolata

tlmgr: cannot find package iconsolata, searching for other matches:

Packages containing `iconsolata' in their title/description:

Packages containing files matching `iconsolata':

This means probably iconsolata is missing in my distribution. If this true how to install the font?


The meaning of tlmgr: cannot find package iconsolata is that tlmgr doesn't know a package named iconsolata, not that iconsolata is not installed on your system. This is because you made a typo; you should search for inconsolata instead of iconsolata. On my end, tlmgr info inconsolata yields

package:     inconsolata
category:    Package
shortdesc:   A monospaced font, with support files for use with TeX
longdesc:    Inconsolata is a monospaced font designed by Raph Levien. This package contains the font (in both Adobe Type 1 and OpenType formats) in regular and bold weights, with additional glyphs and options to control slashed zero, upright quotes and a shapelier lower-case L, plus metric files for use with TeX, and LaTeX font definition and other relevant files.
installed:   Yes
revision:    42871
sizes:       doc: 645k, run: 1273k
relocatable: No
cat-version: 1.112
cat-date:    2017-01-04 22:39:25 +0100
cat-license: oflapache2lppl1.3
cat-topics:  font font-mono font-type1 font-otf font-t1enc
collection:  collection-fontsextra

and according to the R's warning, you will find the installed status set to No.

If you want to install a package via tlmgr, you can use the tlmgr install command. To answer the question title, the standard way to see if something is installed on your TeX Live is to use the kpsewhich command, e.g.,

~$ kpsewhich inconsolata.sty

I used the word package, but this does not mean a LaTeX package (files with the .sty extension). Package here is a TeX Live terminology.

Hereafter, package[l] detones a LaTeX package and package[t] denotes a TeX Live one. A package[t] is a bundle of files to provide a certain function. A font package[t] such as inconsolata typically contains

  • font definition file (*.fd),
  • encoding definition file (*.enc),
  • TeX font metric file (*.tfm),
  • font itself (e.g., *.otf),
  • package[l] (*.sty), etc.

So, when you run tlmgr info inconsolata, tlmgr looks for the inconsolata package[t] instead of inconsolata.sty.

Then, what determines whether TeX Live knows a package[t] of a certain name? TeX Live has a database of package[t]s named texlive.tlpdb, which is usually located in TEXMFROOT/tlpkg. When there is no information on this database, tlmgr info claims it cannot find the package[t].

  • you are true. But in my case installed status in yes.
    – alhelal
    Nov 11 '17 at 11:06
  • @alhelal what do kpsewhich inconsolata.sty and kpsewhich zi4.sty say?
    – yudai-nkt
    Nov 11 '17 at 11:16
  • $ kpsewhich inconsolata.sty /usr/local/texlive/2017/texmf-dist/tex/latex/inconsolata/inconsolata.sty $ kpsewhich zi4.sty /usr/local/texlive/2017/texmf-dist/tex/latex/inconsolata/zi4.sty
    – alhelal
    Nov 11 '17 at 11:56
  • @alhelal TeX Live installation then has no problem and you should be able to use them in a LaTeX document. IMHO, this site (or I at least) cannot be of much help for why R issues such a warning...
    – yudai-nkt
    Nov 11 '17 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.