10

In Zotero, there is a 'language' field which is filled out with the appropriate languages of the bibliography item. However, it is shown as such in the bibliography. I think it would be better to omit. Is there another way to remove the language from the bibliography then to delete the field in Zotero?

enter image description here

\usepackage[
  style=authoryear-ibid,
  maxnames=2,
  backend=biber,
  safeinputenc,
  isbn=false,
  doi=false,
  maxcitenames=2
]{biblatex}

and at the end of the document:

\printbibliography[heading=bibintoc]
5
  • 2
    Show us a minimal compilable document along with a sample .bib entry that shows how you are generating the bibliography. Without that, there's no way to answer your question.
    – Alan Munn
    Nov 12, 2017 at 22:10
  • none of the standard bibligraphy styles would use that field, so you are using one that is, but you have not shown any relevant code. Nov 12, 2017 at 22:14
  • This is not a compilable document, and you haven't shown us a sample .bib file entry either.
    – Alan Munn
    Nov 12, 2017 at 22:22
  • you tagged the question bibtex but now you have provided more of a fragment it's clear you are not using bibtex at all but biber, Nov 12, 2017 at 22:24
  • Note: the content of the language field should contain the language of the bibliography item itself, not the language of the publication! It should be entered in the format 'en-US', 'fr-FR' etc.
    – Max N
    Nov 13, 2017 at 13:29

1 Answer 1

13

You can clear selected fields/lists/names using \AtEveryBibitem{...}. Since language is a list, we use \clearlist to clear it.

\documentclass[letterpaper,12pt]{article}
\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}

@book{Test2001,
    Author = {A Test},
    Language = {English},
    Publisher = {{MIT} Press},
    Title = {This is the title},
    Year = {2001},
}
\end{filecontents*}
\usepackage[
  style=authoryear-ibid,
  maxnames=2,
  backend=biber,
  safeinputenc,
  isbn=false,
  doi=false,
  maxcitenames=2
]{biblatex}
\AtEveryBibitem{\clearlist{language}}
\addbibresource{\jobname.bib}
\begin{document}
\cite{Test2001}
\printbibliography[heading=bibintoc]
\end{document}

output of code

3
  • +1 Why is clearlang=true option not enough? Apr 24, 2023 at 5:31
  • @CyriacAntony The clearlang=true option only clears the language field for entries that match the main language of the document as specified by babel or polyglossia.
    – Alan Munn
    Apr 24, 2023 at 6:15
  • Sure, that makes sense. But, in a beamer document I tried, the main language given as option to babel was english, but 'English' wast still showing in bibliography even though clearlang=true option was given. Apr 24, 2023 at 6:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .