9

I'm using TeXLive 2016, and running with XeLaTeX (the log says "LaTeX2e <2016/03/31> patch level 3").

The following code gives me a warning, as stated in the question title :

\documentclass[11pt,a4paper]{article}
\usepackage{fontspec}
\usepackage[most]{tcolorbox}
\usepackage[french]{babel}
\begin{document}
test
\end{document}

The complete warning says :

Package loading is aborted because of missing \pdf@unescapehex

The problem seems to link with a listingsutf8.sty file, but it resists me, maybe someone can help ?

  • It is only an info. Imho you can ignore it. – Ulrike Fischer Nov 13 '17 at 19:30
  • 2
    @Ulrike Fischer : I know you're right, but I can't help being annoyed that it's not entirely "clean"... – Kempermaz Nov 13 '17 at 19:44
  • You can use the silence package to suppress the warning. – Ulrike Fischer Nov 13 '17 at 20:00
13

Using listingsutf8 with XeLaTeX is usually not a good idea.

The most option loads the tcolorbox libraries loaded by many together with

listingsutf8 external magazine vignette poster

and you probably need none of them. So you can simply do

\usepackage[many]{tcolorbox}

and the warning will disappear. For code listings you can use the minted library instead.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.