2

I am using the document class APA 6 (\documentclass[man,a4paper,floatsintext,donotrepeattitle]{apa6}) and Biblatex (\usepackage[style=apa,sortcites=true,sorting=nyt,backend=biber]{biblatex}) to write my thesis. I adapted this to the German settings for APA 6 and it works quite well, but I can't get rid of the comma in these situations:

enter image description here

The highlighted section in yellow below is the one I don't want in the German citation version (for English APA6, it would be correct). Has anyone got an idea of how to get rid of these commas (in the text and in the bibliography)?

MWEB:

 \documentclass[man,a4paper,floatsintext,donotrepeattitle]{apa6}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage{csquotes}
\usepackage[style=apa,sortcites=true,sorting=nyt,backend=biber]{biblatex}
\DeclareLanguageMapping{german}{german-apa}
\usepackage{booktabs}
\DefineBibliographyStrings{ngerman}{
   andothers = {{et\,al\adddot}},}
\usepackage{hyperref}
\addbibresource{\jobname.bib}
\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}

@article{varazzani_noradrenaline_2015,
    title = {Noradrenaline and Dopamine Neurons in the Reward/Effort Trade-Off: A Direct Electrophysiological Comparison in Behaving Monkeys},
    volume = {35},
    issn = {0270-6474, 1529-2401},
    shorttitle = {Noradrenaline and Dopamine Neurons in the Reward/Effort Trade-Off},
    pages = {7866--7877},
    number = {20},
    journaltitle = {Journal of Neuroscience},
    author = {Varazzani, C. and San-Galli, A. and Gilardeau, S. and Bouret, S.},
    date = {2015},
    langid = {english}
}



\end{filecontents}
\shorttitle{Gedächtnisleistung und Pupillenweitung}
\begin{document}
Text \parencite{varazzani_noradrenaline_2015}
\printbibliography[heading=bibintoc]
\end{document}
13
  • 3
    Please provide a MWEB. Commented Nov 14, 2017 at 9:25
  • 1
    I reinforce David's request. But in the meantime, a guess. Does this answer help? tex.stackexchange.com/a/400528/105447
    – gusbrs
    Commented Nov 14, 2017 at 9:43
  • 1
    An MWE/MWEB is really required to properly diagnose what is going on here. But you might also want to check your versions of biblatex, Biber and biblatex-apa. I seem to remember there was a problem with an older version of biblatex-apa that would incorrectrly enable the Oxford comma (comma before and) for German even though that is not wanted. That was fixed by an update a while ago.
    – moewe
    Commented Nov 14, 2017 at 9:47
  • Thank you for your answers, I edited my question and included an MWEB. I will have a look at the other tips as well.
    – Anne B.
    Commented Nov 14, 2017 at 9:49
  • 2
    Your versions of biblatex and biblatex-apa as well as Biber are out of date. The current version of biblatex is 3.8a, that of Biber 2.8 and biblatex-apa is at 7.5. I'd suggest an update, but you need to be aware of the fact that updates could always cause trouble. How soon does the document need to be ready?
    – moewe
    Commented Nov 14, 2017 at 10:14

1 Answer 1

2

As noted in the comments, this is fixed for more recent versions of biblatex-apa, but it's not too hard to make things work without upgrading.

You need to redefine \finalandcomma for the ngerman language:

\DefineBibliographyExtras{ngerman}{
  \def\finalandcomma{}
}

Also, I notice you have ngerman as your babel language, but then you instruct biblatex-apa to use german. Shouldn't they be the same?

If you want und instead of &, then add this to the preamble of the MWE below:

\AtEveryCitekey{%
  \renewcommand{\finalnamedelim}{%
    \ifnum\value{liststop}>2 \finalandcomma\fi\addspace\bibstring{and}\space}}
\AtBeginBibliography{\renewcommand*{\finalnamedelim}{%
    \ifthenelse{\value{listcount}>\maxprtauth}
      {}
      {\ifthenelse{\value{liststop}>2}
        {\finalandcomma\addspace\bibstring{and}\space}
         {\addspace\bibstring{and}\space}}}}

Here's my MWE. It works with your versions of biblatex, biber, and biblatex-apa. (It uses & instead of und, but I assume you've changed other things to deal with this, since & is hard coded in biblatex-apa.)

\documentclass[man,a4paper,floatsintext,donotrepeattitle]{apa6}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage{csquotes}
\usepackage[style=apa,sortcites=true,sorting=nyt,backend=biber]{biblatex}
\DeclareLanguageMapping{ngerman}{ngerman-apa}% <-- use ngerman mapping
\usepackage{booktabs}
\DefineBibliographyStrings{ngerman}{
   andothers = {{et\,al\adddot}},}
\DefineBibliographyExtras{ngerman}{% <-- redefine finalandcomma for ngerman
  \def\finalandcomma{}
}
\usepackage{hyperref}
\addbibresource{\jobname.bib}
\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}

@article{varazzani_noradrenaline_2015,
    title = {Noradrenaline and Dopamine Neurons in the Reward/Effort Trade-Off: A Direct Electrophysiological Comparison in Behaving Monkeys},
    volume = {35},
    issn = {0270-6474, 1529-2401},
    shorttitle = {Noradrenaline and Dopamine Neurons in the Reward/Effort Trade-Off},
    pages = {7866--7877},
    number = {20},
    journaltitle = {Journal of Neuroscience},
    author = {Varazzani, C. and San-Galli, A. and Gilardeau, S. and Bouret, S.},
    date = {2015},
    langid = {english}
}
\end{filecontents}
\shorttitle{Gedächtnisleistung und Pupillenweitung}
\begin{document}
Text \parencite{varazzani_noradrenaline_2015}
\printbibliography[heading=bibintoc]
\end{document}

enter image description here

1
  • Thank you very much, this works perfectly. Also, I changed "german" to "ngerman" for all the settings. I looked up my citation manual, the "&" is correct for \parencite, the "und" for \textcite.
    – Anne B.
    Commented Nov 16, 2017 at 12:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .