1

I have this "Could not start the command: Build & View" error, with the difference to the existing questions, that it works for old files I created in the past. And for unsaved files. But once I save the tex file, it stops working and throws that error. Given that in the folders of the old files, tex always created a bunch of files like: .aux .log etc. and it didn't create that for the new documents, I could imagine it has something to do with this.

I didn't use TexStudio for some time, so when I started it today it prompted me with an update. I downloaded and executed the update without uninstalling the old version. Could that have something to do with it?

This is a code snippet which works in an unsaved document but throws the error if I save the tex file:

\documentclass{article}
\begin{document}
    content...
\end{document}

EDIT: I tried the advice for the other questions anyway and it didn't work. Neither putting the explicit path for the pdfviewer, nor deleting the config file.

Latest try (Command line):

$ pdflatex ./SectionB.tex
This is pdfTeX, Version 3.14159265-2.6-1.40.17 (MiKTeX 2.9.6210 64-bit)
entering extended mode
! I can't write on file `SectionB.log'.
Please type another transcript file name: test.log
! I can't write on file `test.log'.
Please type another transcript file name:

On a different file it actually worked so I am not sure what is the problem...

UPDATE: So apparently the command pdflatex [file] works if the bash is in the user folder, but not if it is located where I want to store the file. It is in a google drive folder, so I wonder if that is a reason for it not to work. Anyway so I generated the .log .aux and .pdf files in the user folder and put them in the google drive folder. Now the build and view doesn't throw the same error, but instead goes through without the popup, but the message window shows: process exited with errors. Looking at the log: SectionB.tex Warning No SectionB.aux This is false. There is an .aux file in the same folder. It continues to show the same pdf without updating changes.

closed as off-topic by Troy, TeXnician, Stefan Pinnow, user36296, egreg Dec 10 '17 at 23:01

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – Troy, TeXnician, Stefan Pinnow, user36296, egreg
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to TeX.SX! You can help us to help you by providing the code for a small compilable document that shows your problem/ error message. Just edit your question and add missing code. Do you compiled with pdflatex? – Bobyandbob Nov 14 '17 at 12:38
  • @Bobyandbob the default of the build and view button, which is pdflatex as far as I know, so yes – Felix B. Nov 14 '17 at 12:42
  • @Bobyandbob If I save an old file with a new name the build and view doesn't work either – Felix B. Nov 14 '17 at 13:02
  • Does build or pdflatex without view work? – Bobyandbob Nov 14 '17 at 13:07
  • just the compile button? No not either. – Felix B. Nov 14 '17 at 13:08

Browse other questions tagged or ask your own question.