I installed TexLive 2013 from the installer provided at CTAN on Ubuntu Linux. I have been able to use latex and pdflatex commands so far, but I have a problem with bibtex. Is there any setting (such as exporting an environmental variable) that I needed to make to let bibtex know where .bst files are?

The bibtex command does not seem to recognize the .bst files stored under texlive/2013/texmf-dist/bibtex/bst/revtex/, texlive/2013/texmf-dist/bibtex/bst/natbib/, etc.

However, the .bst files under texlive/2013/texmf-dist/bibtex/bst/base/ seem to be recognized.

The style file I actually want to use is texlive/2013/texmf-dist/bibtex/bst/revtex/aipnum4-1.bst. If I do $ kpsewhich aipnum4-1.bst I get nothing.

I didn't change anything on the tex system after I installed the TexLive 2013. I didn't add a file manually, or I didn't update the TexLive.


According to the comment, I am adding a small example. The following set of sample.tex and fa.bib can be compiled to a PDF with pdflatex and bibtex. The plain.bst is under texlive/2013/texmf-dist/bibtex/bst/base/. If I change \bibliographystyle to aipnum4-1 or the other styles commented out, the reference section is not produced, and the citation is noted by a question mark.




This is the minimum story I heard from the king of Elephants. \cite{pa}

% .. works
% .. does not work



  author =   {Elegant Elephant},
  title =    {Eggs of Elephants are Elegant},
  journal =  {Elite Elephants},
  year =     {2399},
  volume =   3,
  pages =    447,

Edit 2

I found that my setting of PATH environmental variable (as well as MANPATH and INFOPATH) was inappropriate. I had set them in /etc/profile as


I corrected it to

INFOPATH=/usr/local/texlive/2013/texmf-dist/doc/info:$INFOPATH; export INFOPATH
MANPATH=/usr/local/texlive/2013/texmf-dist/doc/man:$MANPATH; export MANPATH
PATH=/usr/local/texlive/2013/bin/x86_64-linux:$PATH; export PATH

My Ubuntu package manager seems to have installed its own tex system under /usr/share/texlive/ and /usr/share/texmf/, probably because another package depends on the tex package.

With the first, wrong setting of PATH, ubuntu installation of tex-related executables had precedence over my installation of texlive 2013 directly from CTAN. For example, kpsewhich at /usr/bin/kpsewhich was used instead of /usr/local/texlive/2013/bin/x86_64-linux/kpsewhich. As a result, when I did

kpsewhich plain.bst

I got


which was installed by ubuntu's tex package. This package installed only bibtex/bst/base/ but not bibtex/bst/revtex/ or other bst directories, kpsewhich aipnum4-1.bst resulted in empty string.

Now, with the corrected PATH setting,

kpsewhich aipnum4-1.bst



The above sample tex file can be compiled to a PDF with any of the bst files listed in the comment.

It looks that ubuntu's tex package did not install pdflatex, and I had used /usr/local/texlive/2013/bin/x86_64-linux/pdflatex happily so far.

I realized my mistake while reading this answer:


  • Welcome to TeX.SX! Please help us (and also you) and add a minimal working example with bibliography (MWEB), that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass and ending with \end{document}. – Bobyandbob Nov 14 '17 at 12:53
  • did you install the .bst files for revtex and natbib separately from the main installation? if so, you have to update the database. how to do that is shown in this question: How to update biblatex in ubuntu. – barbara beeton Nov 14 '17 at 13:26
  • All these .bst came with TexLive, and I didn't do any manual installation. – norio Nov 14 '17 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.