2

I am using latex for my thesis, using texmaker and mendley for the references. I have used latex and references beforem but I always used Overleaf, so I don't know what I am doing wrong with TexMaker because my refrences appear with a question mark [?] instead of with a number.

This is my code:

% !TEX TS-program = pdflatex
% !TEX encoding = UTF-8 Unicode

% IMPORT SETTINGS
\documentclass[12pt,a4paper,twoside,openright]{report}
\usepackage[justification=centering]{caption}

\input{../include/settings.tex}

% Documents' beginning
\begin{document}

\pagenumbering{roman}
\setcounter{page}{0}

% TITLE PAGE
\input{../include/title_page.tex}

% ENTITIES
\input{../include/empty_page.tex}
\input{../include/entities.tex}

% COPYRIGHT
\input{../include/empty_page.tex}
\input{../include/copyright.tex}

% DEDICATION [OPTIONAL]
% \input{../include/empty_page.tex}
% \input{../include/dedication.tex}

% ACKNOWLEDGMENTS [OPTIONAL]
\input{../include/empty_page.tex}
\input{../include/acknowledgments.tex}

% FINANCING [IF APPLIABLE]
% \input{../include/empty_page.tex}
% \input{../include/financing.tex}

% EPIGRAPH [OPTIONAL]
% \input{../include/empty_page.tex}
% \input{../include/epigraph.tex}

% RESUMO
\input{../include/empty_page.tex}
\input{../abstract/abstract_pt.tex}

% ABSTRACT
\input{../abstract/abstract_en.tex}

%\begin{spacing}{1} % change vertical space between toc, lof, lot and glossaries entries
\printglossaries
\listoffigures
\listoftables
\tableofcontents
%\end{spacing}

% INTRODUCTION
\input{../chapters/introduction/introduction_main.tex}

% METHODS
\input{../chapters/methods/methods_main.tex}

% RESULTS
\input{../chapters/results/results_main.tex}

% CONCLUSION
\input{../chapters/conclusion/conclusion_main.tex}

% REFERENCES / BIBLIOGRAPHY
\cleardoublepage
\bibliography{../references/TESE}
\bibliographystyle{ieeetr}


% INDEX [OPTIONAL]
% Each time you want to add an entry to index you need to use \index{text}
\newpage\null\newpage
\printindex

% APPENDICES [OPTIONAL]
\newpage\null\newpage
\input{../chapters/appendices/appendices_main.tex}



\end{document}
\end{document}

Here is an example of my .bib file called "TESE" generated through Mendeley:

@article{Manganaro2016,
author = {Manganaro, Lorenzo and Attili, Andrea and Dalmasso, Federico and Fausti, Federico and Giordanengo, Simona and Mazza, Giovanni and Monaco, Vincenzo and Sacchi, Roberto and Vignati, Anna and Cirio, Roberto},
journal = {PoS},
keywords = {Intro},
mendeley-tags = {Intro},
title = {{Control of the dose distribution in charged particle therapy}},
url = {http://pos.sissa.it/},
year = {2016}
}
@article{Katiaparodiphysikuni-muenchende2017,
author = {Katiaparodiphysikuni-muenchende, Cc Katia Parodi and Crespo, Paulo},
file = {:D$\backslash$:/Tese/mail{\_}Tese{\_}1.pdf:pdf},
pages = {3--5},
title = {{Master Thesis in M{\"{u}}nchen - Rita Rego}},
year = {2017}
}

Hope someone can help me!

  • 2
    Welcome to TeX.Stackexchange! Did you run bibtex? – user36296 Nov 14 '17 at 15:52
  • @samcarter how should I run it? I am sorry if it seems like a "stupid" question but overleaf always did it automatically – Rita Viegas Nov 14 '17 at 15:58
  • Don't worry, this is one of the most often asked questions :) See tex.stackexchange.com/questions/63852/… for some explanation. And specifically for texmaker: tex.stackexchange.com/a/119823/36296 – user36296 Nov 14 '17 at 16:01
  • @samcarter I already read what you sent but how do I run bibtex? If I run my .bib it appears this error: Impossible to iniate command. pdflatex -synctex=1 -interaction=nonstopmode %.tex – Rita Viegas Nov 14 '17 at 16:14
  • Go to your main .tex document, run pdflatex first, then press F1 to run bibtex and then again two times pdflatex – user36296 Nov 14 '17 at 16:19
1

Well, your given code is not compilable and have parts like

\bibliography{../references/TESE}
\input{../include/settings.tex}

I can not proof that the path ../references/TESE to the bib file TESE.bib is correct. And we do not have your \inputed files in your code ...

To get rid of that problems I suggest to start evaluating your error(s) with the following MWE, name it for example mwe.tex:

\RequirePackage{filecontents}
\begin{filecontents}{\jobname.bib}
@article{Manganaro2016,
  author   = {Manganaro, Lorenzo and Attili, Andrea and 
              Dalmasso, Federico and Fausti, Federico and 
              onaco, Vincenzo and Sacchi, Roberto and 
              Vignati, Anna and Cirio, Roberto},
  journal  = {PoS},
  keywords = {Intro},
  mendeley-tags = {Intro},
  title    = {{Control of the dose distribution in charged particle 
              therapy}},
  url      = {http://pos.sissa.it/},
  year     = {2016},
}
@article{Katiaparodiphysikuni-muenchende2017,
  author  = {Katiaparodiphysikuni-muenchende, Cc Katia Parodi and 
             Crespo, Paulo},
  journal = {missing journal},
  file    = {:D$\backslash$:/Tese/mail{\_}Tese{\_}1.pdf:pdf},
  pages   = {3--5},
  title   = {{Master Thesis in M{\"{u}}nchen - Rita Rego}},
  year    = {2017},
}
\end{filecontents}


\documentclass{article}

\begin{document}

\cite{Katiaparodiphysikuni-muenchende2017} and \cite{Manganaro2016}.

\bibliographystyle{ieeetr} % ieeetr
\bibliography{\jobname} % print bibliography created with filecontents

\end{document}

Then I get the following result without errors:

resulting pdf

Please copy this code to your computer/overleaf and compile it using the usual chain pdflatex mwe.tex, bibtex mwe.aux, pdflatex mwe.tex, pdflatex mwe.tex.

That should compile now without errors and it should not contain any ?.

  • If that is so, I guess that your given path to your bib file is wrong. Correct it and retry.
  • If that is not so, the compiling of bibtex mwe.aux has not worked. Then please ask the support of overleaf for help!

After you get an compiling mwe.tex try your bib file with the mwe to make sure, that the bib file does not have errors.

  • 2
    Isn't that the very same answer again? Why no mark as dupe? – Johannes_B Nov 14 '17 at 19:28
  • By the way, the LaTeX wikibook needs serious work on bibliograpies. Any hekp to fix it is welcome. – Johannes_B Nov 14 '17 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.