3

I noticed that after I symlinked the 09-texlive-fonts.conf file from /etc/fonts/conf.d it interfered with fonts system wide, notably firefox. On https://reddit.com/r/aww all the fonts in the header were showing 'squares' and in other applications font glyphs were not even rendering.

Is there any way to install the TexLive fonts without interfering with the system? Currently I'm doing:

sudo apt install lmodern

Which seems to work without any side effects, but this solution won't work on every Linux distribution.

  • Which version of Firefox do you have? I've been noticing font issues with Firefox since last release (FF57 codename Quantum). – Paulo Cereda Nov 16 '17 at 16:03
  • I have 57 as well. – jdw Nov 17 '17 at 15:28
  • Try the security level thingy Domenico has suggested in his answer and see if it works. FF57 has driven me crazy lately until I tweaked the sandboxing level. Edit: I don't think TeX Live fonts are the ones to blame, just a nuisance of the new version of FF. – Paulo Cereda Nov 17 '17 at 16:03
4

The recommended way is to set in about:config

security.sandbox.content.read_path_whitelist

to

/usr/local/texlive/

Our issue is related to a bug in FF57 (https://bugzilla.mozilla.org/show_bug.cgi?id=1418240), which is fixed in FF58.

~~~~~~~~~~~~

Other (not recommended) solutions:

  1. Prevent pages from overriding default fonts by going to preferences and selecting 'advanced' under fonts. Uncheck the relevant box and save the change.

    Ensure that the default fonts are set to fonts available under /usr/share/fonts and not from TeX Live.

    This option is perfectly safe, but rendering of some pages will be sub-optimal due to font substitution (and doesn't cover all web pages, as far as I have seen).

  2. In Firefox address bar, go to about:config, then search for

    security.sandbox.content.level

    and set this string to 2. This change has security implications. It reduces the effectiveness of Firefox's sand-boxing feature. Enable this only as a last resort or temporarily for testing purposes.

  • I think it would be better to put EDIT 2 part to the top as it is the best solution. Each edit is versioned so no need to explicitly say EDIT X... – alick Nov 21 '17 at 2:29
  • 1
    Setting the level to 2 is sufficient. Still not recommended, but better than 1. The other option is to prevent pages overriding default fonts in the preferences. – cfr Nov 23 '17 at 23:23
  • 2
    I hope you will not object to my edits, but people will likely use this sooner rather than later. I've re-ordered the other options, so the reduction in security is last; removed unneeded restarts; made the less secure option a bit less less secure; generalised the secure other option. (Installing specific fonts may help on certain pages, but only if those pages require those fonts. The more general solution is to force use of the default fonts.) – cfr Nov 23 '17 at 23:33
  • No, no objections, indeed a thousand thanks! The recommended workaroud is the first, with /usr/local/texlive/. I have kept the others for historical reasons, but clearly they must be avoided – Domenico Cufalo Nov 24 '17 at 12:57
  • This FF57 setting security.sandbox.content.read_path_whitelist does not exist in about:config on my Mac OS X. Should it be created manually? – user4686 Nov 24 '17 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.