0

First I should say that I'm sorry if the question is too much broadly scoped, but I was not able to produce a MWE with this bug.

My trouble is that I'm writing my PhD thesis in LaTeX (which I've used exclusively for almost a decade now), with the template required by the institution (a package not on CTAN).

I did some light tweaking in the package, for it to work with XeTeX. The trouble is that, every time the character 'u' is capitalized (like in a title, heading or citation), a 'V' is produced, instead of a 'U'.

Is anyone aware of any incompatibility that may produce such results?

Thank you, for any input.

2
  • 1
    Hi, I think it would still be helpful to see some kind of MWE, even if not available openly. I'm not aware of any problems as you state, but my guess would be that it may have to do with the chosen font or character encoding. Also if it has worked for the last 10 years, try to think of what you have changed now to cause this problem. You have to address this problem systematically ... so start off with what worked before and add in changes one by one until you reproduce the problem. This way you can identify the culprit.
    – Tina
    Nov 15 '17 at 0:54
  • I've just started working with the template. The only thing I changed was add fontspec and polyglossia, so I could use XeTeX (that which I'm doing for the past few years, with no problems). I forgot to add that the issue also occurs with LuaLaTeX. Nov 15 '17 at 1:22
3

Thanks Tina, for your input. I had already done that, but it must have slipped me, and I found the error in the first minutes of looking into it.

I use the polyglossia features to automatically change fonts when I'm writing something not in Portuguese, so I had in my class:

\RequirePackage{polyglossia}
\setdefaultlanguage{brazil}
\setotherlanguage[variant=usmax]{english}
\newfontfamily\englishfont{lmroman12-italic.otf}[BoldFont=lmroman10-bolditalic.otf]
\setotherlanguage[variant=classic]{latin}
\newfontfamily\latinfont{lmroman12-italic.otf}

Which puts foreign expressions in italics (as required per official Brazilian norms). For some reason, the [variant=classic] option for the Latin language was spilling over my main language. Getting rid of the option (which reverts back to the default 'modern'—and makes no difference to me) did the trick!

I'll report the bug to the polyglossia team. In retrospect, I should have suspected of this earlier. My little knowledge of Latin includes the fact that there is something "funny" in the way it treats the specific characters 'u' and 'v'... but alas, hindsight is always 20/20.

2
  • Well done for finding out what the problem was :)
    – Tina
    Nov 15 '17 at 2:03
  • 1
    As it turns out, there was a bug report buried in polyglossia's GitHub page, from last January. But the wording of the OP made it difficult to show on a Google search. Nov 15 '17 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.