0

I read several posts on this topic here but couldn't solve my problem. I want to write in both English and Russian and I'm using Lyx. I tried to paste different codes in the preamble to no avail...

What options should I select in Document -> Settings -> Language and what should I paste in the preamble?

If that's relevant, usually I just type in english.

  • I installed a bunch of packages from MiKTeX and everything's working now but I have no idea which ones solved the problem. Also, whenever I write in russian I don't need to select the text and change the language in Lyx for some reason. – aadcg Nov 19 '17 at 14:46
1

I don't know Russian, but the following worked for me:

  1. Start a new document with document language set to english (in Document > Settings > Languages).

  2. Type some English.

  3. Type some Russian. Select the Russian text and go to Edit > Text Style > Customized. For the language, select "Russian".

Now, whenever you want to mark text as English or Russian, it is easier (now that LyX sees you use more than one language it creates a new menu to help). Select the text and go to Edit > Language and choose either Russian or English.

Here is the minimal example that resulted for me after the above steps:

#LyX 2.2 created this file. For more info see http://www.lyx.org/
\lyxformat 508
\begin_document
\begin_header
\save_transient_properties true
\origin unavailable
\textclass article
\use_default_options true
\maintain_unincluded_children false
\language english
\language_package default
\inputencoding auto
\fontencoding global
\font_roman "default" "default"
\font_sans "default" "default"
\font_typewriter "default" "default"
\font_math "auto" "auto"
\font_default_family default
\use_non_tex_fonts false
\font_sc false
\font_osf false
\font_sf_scale 100 100
\font_tt_scale 100 100
\graphics default
\default_output_format default
\output_sync 0
\bibtex_command default
\index_command default
\paperfontsize default
\use_hyperref false
\papersize default
\use_geometry false
\use_package amsmath 1
\use_package amssymb 1
\use_package cancel 1
\use_package esint 1
\use_package mathdots 1
\use_package mathtools 1
\use_package mhchem 1
\use_package stackrel 1
\use_package stmaryrd 1
\use_package undertilde 1
\cite_engine basic
\cite_engine_type default
\biblio_style plain
\use_bibtopic false
\use_indices false
\paperorientation portrait
\suppress_date false
\justification true
\use_refstyle 1
\index Index
\shortcut idx
\color #008000
\end_index
\secnumdepth 3
\tocdepth 3
\paragraph_separation indent
\paragraph_indentation default
\quotes_language english
\papercolumns 1
\papersides 1
\paperpagestyle default
\tracking_changes false
\output_changes false
\html_math_output 0
\html_css_as_file 0
\html_be_strict false
\end_header

\begin_body

\begin_layout Standard
Hello, your name is 
\lang russian
андрэ
\lang english
.
\end_layout

\end_body
\end_document
  • I followed your steps but got this (ibb.co/bKeJhm) error. – aadcg Nov 18 '17 at 17:51
  • Do you get the same error when you try the example file I posted? (just paste it into a text file and save as a .lyx) – scottkosty Nov 18 '17 at 18:33
  • Yes, I get the same exact error. – aadcg Nov 18 '17 at 18:46
  • @андрэ If you happen to be using Ubuntu just install the packages texlive-lang-cyrillic and texlive-fonts-extra. Otherwise I'm not sure. – scottkosty Nov 18 '17 at 19:12
  • I believe those packages do not belong to MiKTeX. – aadcg Nov 18 '17 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.