1

I want to use newtxtext and newtxmath fonts in combination with siunitx. I also need bold math so I added the bm package as described in: Sans-serif bold math with newtxmath

Now I am facing font shape line warnings:

LaTeX Font Warning: Font shape `OT1/ntxtlf/sb/n' undefined

Does anyone know a solution? Especially which characters are subsituted?

Thank you!

MWE:

\documentclass[12pt, a4paper, twoside]{book} 
\usepackage{newtxtext}
\usepackage[libertine, vvarbb]{newtxmath}
\usepackage{bm} %Bold math
\usepackage{siunitx}

\begin{document}     
Test
\end{document}
1
  • 2
    Why are you loading the option libertine if your text font is newtxtext? Nov 21 '17 at 9:29
1

Sorry to get to you so late. Just saw this question in a search for duplicates of another.

This problem is unrelated to siunitx and (on TeX Live 2019) still appears if you omit the package. As Ulrike Fischer hinted, the problem is that you loaded newtxtext together with the libertine option of newtxmath. For bold upright letters (such as capital Greek letters), this causes the package to look for a semibold weight of the Times-based text font, which does not exist (newtxlf/sb/n is New Times with lining figures, semibold weight, upright shape).

To fix this, load the libertine package as your text font instead. You should give it the semibold option to match the bold math.

\documentclass[12pt, a4paper, twoside]{book} 
\usepackage[lining, semibold, type1]{libertine}
\usepackage[T1]{fontenc}
\usepackage[libertine, vvarbb]{newtxmath}
\usepackage{bm} %Bold math
\usepackage{siunitx}

\begin{document}     
Test
\end{document}

I loaded libertine with the type1 option to prevent the package from loading fontspec on LuaLaTeX or XeLaTeX. Although there are other workarounds, this is mainly so that upright capital Greek letters such as \Delta will still work. Legacy packages such as newtxmath look for them in the 7-bit OT1 encoding.

In the modern toolchain, with LuaLaTeX and XeLaTeX, you can instead load libertinus to use the Libertinus Math font, or unicode-math followed by \setmathfont{Libertinus Math}.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.