1

I get a "LaTeX Error: Option clash for package inputenc." in a line which is a blank line right after \usepackage[utf8]{inputenc}.

\documentclass{RITA}
\usepackage[T1]{fontenc}
\usepackage{url}
\usepackage[spanish,english]{babel}
\usepackage{verbatim}
\usepackage[num]{abntex2cite}
\usepackage{cite}
\renewcommand\citeleft{[}
\renewcommand\citeright{]}
\usepackage[a4paper]{geometry}
\usepackage{graphicx}
\usepackage[latin1]{inputenc}
\usepackage[utf8]{inputenc}
  • 2
    Welcome to TeX.SE! You called inputenc twice. Perhaps class RITA called it too. Call it only one time, for example \usepackage[utf8]{inputenc} ... – Kurt Nov 22 '17 at 2:31
  • 1
    The option of inputenc should match the encoding of your tex file. Else, the package is pretty useless. – Johannes_B Nov 22 '17 at 4:10
2

Your preamble has two consecutive \usepackage{inputenc} statements, but they are loaded with mutually exclusive and incompatible options. (Just in case it isn't clear: A file can have only one input encoding at a time.) After inputenc has been loaded with the option latin1, it makes no sense to load the package again with the option utf8 -- or vice versa. One would certainly never load the package with both options, right?

You need to decide which option is correct for your input file: Maybe it's latin1, maybe it's utf8, and maybe it's something else altogether. Only you can tell.

  • 1
    Also, it should be mentioned that all files of one project should have the same encoding. – Johannes_B Nov 22 '17 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.