0

Before the use of TTF/OTF became more prevalent in LaTeX, we used to use mostly a set of several fonts which were available since LaTeX 2.09: Jerusalem, TelAviv, DeadSea, OldJaffa.

enter image description here

I really like them... have TrueType/OpenType versions of them ever been created? If so, where can we get them?

1
  • @DavidCarlisle: Those seem to only be the Culmus project fonts, which are great but not what I'm looking for. Indeed, there are PFA versions of them.
    – einpoklum
    Nov 27, 2017 at 19:50

1 Answer 1

4

If you go here on CTAN:

https://ctan.org/tex-archive/language/hebrew/hebtex/fonts/pccode

You can download archive pcfonts.zip. Unzip it, and look inside the INPUTS/MF folder. There, you will find metafonts *.mf for the four requested fonts.

The free program FontForge (Linux and Windows, possibly OS/X) is capable of opening the metafonts, and converting them to Unicode Open Type (or TrueType) fonts. This is easy to do.

I just tried one, and it works. But I have no idea whether the encoding is what you expected.

Note that there is already a "Jerusalem" TrueType font, but it is not equivalent to the one you want (it is a Latin font with Hebrew-looking style). So, you will need to give the fonts unique names.

The above-linked font package has a license "no commercial use," so that limits what you can do with them.

EDIT: Regarding the power of 2: A TrueType font must have have a "grid" that is 1024 or 2048 (sometimes 4096) internal units. Most have 1024. Also, the co-ordinates of each control point must be an integer. But if the font is Open Type with PostScript outlines (recommended), then the grid is 1000, and co-ordinates may be decimal.

When the *.mf is opened in FontForge, it reads the existing grid (if known) or guesses (from its own default settings). If it uses 1024 and you try to export Open Type, it will inform you that it expected 1000 grid. If it uses 1000 and you try to export TrueType, it will inform you that the grid must be 1024 or 2048 (power of 2), and that points must be at integer co-ordinates.

How to fix that: In FontForge menu, Element > Font Info > General > Em Size. Change to 1000 for Open Type with PostScript outlines. Be sure that "scale outlines" is checked. Then go to Element > Font Info > Layers and select "all layers cubic". Save. When you generate the font, choose "Open Type (CFF)".

During font validation, there may be error messages. Usually "missing extrema" may be ignored. You should correct glyphs that are drawn the wrong way (outermost outline must be clockwise), and correct glyphs that self-intersect. In most cases, you may generate the font, even if it has errors.

Sometimes, you will see "bad glyph name" or "bad blues values." In many cases these self-correct if you close the program, then re-open the file.

Regarding the missing files: I do not know what to do about that. Are they really essential? I assumed that you are using LuaLaTeX or XeTeX with the fontspec package, so you can load an Open Type font without need for TeX metrics or font definition files.

4
  • Also - looking at the package again, the INPUTS/MF folder doesn't contain most/all of the relevant fonts. For examples, jerus10.mf is not in there. I actually do have it, but when I try the conversion I get errors: "Self-intersecting; Missing points at extrema; Non-integral coordinates". What do I do about all that?
    – einpoklum
    Nov 28, 2017 at 9:36
  • @einpoklum I modified my answer.
    – user139954
    Nov 28, 2017 at 16:17
  • So, some of the glyphs are messed up - in the fontforge display and after export. But I've +1'ed you anyway - thanks.
    – einpoklum
    Nov 28, 2017 at 16:53
  • @einpoklum Sorry I could not provide more. But I would not know whether or not the glyphs were accurate.
    – user139954
    Nov 28, 2017 at 17:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .