3

I have looked both the answers here and here, but could not fix my problem.

A minimal working example is the following

\documentclass{amsart}[11pt]

\usepackage{lipsum}

\usepackage{caption} 
\begin{document}

\lipsum[1]

\begin{table}[h]
  \centering
  \begin{tabular}{cccc}
   1 &2 &3 &4\\ \hline
   1 &2 &3 &4\\ \hline   
   1 &2 &3 &4\\ \hline
   1 &2 &3 &4\\ \hline
  \end{tabular}
\caption{}\label{tab:1}
\end{table}
\lipsum[2]
\end{document}

As it stands, there is too much white space after the caption and above the paragraph below. I can remove it with a command like

\vspace{-2em}

But I probably should refrain from doing that.

Comparing the different document classes between amsart and article, it looks like that amsart moved the caption upward immediately blow the table, without trimming the overall space.

What I have tried:

  1. Setting captionsetup{belowskip=0pt} does nothing;
  2. \setlength{\intextsep}{0pt} trims some space below the caption but killed all of them above the table;
  3. \setlength{\belowcaptionskip}{-8pt} moves the caption inside the table.

Your kind help is appreciated.

  • amsart expects captions to be above tables. – egreg Nov 28 '17 at 9:37
1

The amsart class expects captions to be above tables.

If you prefer them below, use caption features:

\documentclass[11pt]{amsart}
\usepackage{caption}
\usepackage{lipsum}

\captionsetup[table]{position=below}

\begin{document}

\lipsum[1]

\begin{table}[htp]
\centering

\begin{tabular}{cccc}
1 &2 &3 &4\\ \hline
1 &2 &3 &4\\ \hline
1 &2 &3 &4\\ \hline
1 &2 &3 &4\\ \hline
\end{tabular}

\caption{This is the text of the caption}\label{tab:1} 
\end{table}

\lipsum[2]

\end{document}

Note that the syntax is \documentclass[11pt]{amsart} (you have the optional argument in the wrong place).

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.