4

I'm using AUCTeX (version 11.90.2)+RefTeX on Emacs (version 24.5.2). While I'm using the biblatex package, if I do C-c C-c, it would suggest biber as default.

However, if I use the package biblatex-chicago instead, it would suggest that the default option is bibtex instead, even when I have the option backend=biber.

In this situation, I check that the value of the variable LaTeX-biblatex-use-Biber is t, but it is mentioned in this post that the variable LaTeX-biblatex-use-Biber would be removed since AUCTeX version 11.88 because it will be no more needed.

So how do I set biblatex-chicago to behave the same way as biblatex? Many thanks!

  • Does it help if you set LaTeX-biblatex-use-Biber as a file local variable? In your .tex file, try M-x add-file-local-variable RET LaTeX-biblatex-use-Biber RET t RET? – Arash Esbati Nov 29 '17 at 9:01
  • @ArashEsbati, it helps! but i'm using \include{} to manage multiple files, and i have to add the local variable to every file there is. Is there a way to fix this in the .emacs file? or maybe just in the master file? – davyjones Nov 29 '17 at 9:41
  • @ArashEsbati, also even with the local variable set, C-c [ does not prompt options like \parencite, \citeyear and the like as when using just biblatex, neither does it seem to let me find citation entries by searching afterwards. I wonder is it possible to extend the biblatex support to biblatex-chicago, biblatex-mla and so on? – davyjones Nov 29 '17 at 10:27
3

The issue here is that AUCTeX does not have a style file for biblatex-chicago. You can roll your own one which simply loads biblatex.el like this:

;;; biblatex-chicago.el --- AUCTeX style for `biblatex-chicago.sty'

(TeX-add-style-hook
 "biblatex-chicago"
 (lambda ()
   (TeX-run-style-hooks "biblatex"))
 LaTeX-dialect)

;;; biblatex-chicago.el ends here

Set the variable TeX-style-private to a directory of your choice, e.g.:

(setq TeX-style-private "~/.emacs.d/mystyles")

and save biblatex-chicago.el there.

In your .emacs, do

(setq TeX-parse-self t)

and restart Emacs and open your file.

The quick and ugly solution would be to fool AUCTeX with something like this in your preamble:

\usepackage{biblatex-chicago}
\iffalse
\usepackage{biblatex}
\fi

AUCTeX does not parse conditionals, it sees \usepackage{biblatex} and loads biblatex.el right away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.