1

To prepare submission for a journal, I am practically forced to use the sagej documentclass, available here: SAGE. My MWE looks like this:

\documentclass[PCfour,sageh,times,doublespace]{sagej}
% add doublespace for submitting for review
\usepackage{moreverb,url}

%\input{preambleOS}
\usepackage[colorlinks,bookmarksopen,bookmarksnumbered,citecolor=red,urlcolor=red]{hyperref}

\begin{document}
cite like this: \cite{R1} and \citep{R2} and \citet{R2}

but why not like this like this: \cite{Fama1992} and \citep{Fama1992} and \citet{Fama1992}

\begin{thebibliography}{99}
\bibitem[Kopka and Daly(2003)]{R1}
Kopka~H and Daly~PW (2003) \textit{A Guide to \LaTeX}, 4th~edn.
Addison-Wesley.

\bibitem[Lamport(1994)]{R2}
Lamport~L (1994) \textit{\LaTeX: a Document Preparation System},
2nd~edn. Addison-Wesley.
\end{thebibliography}

\bibliography{mwebiblio}
\bibliographystyle{mslapa}

\end{document}

The style mslapa is suggested by the journal, and described as a very generic default style:

"Please note that the files SageH.bst and SageV.bst are included with the class file for those authors using BIBTEX. For APA style references please use mslapa.bst which should be part of most modern TEX distributions. See the above instructions regarding choos- ing the correct reference option."

The bibliography file mwebiblio contains this (when opened in Texworks; I use Texworks and Miktex):

% Encoding: windows-1252

@Article{Fama1992,
  author  = {Eugene F. Fama and Kenneth R. French},
  title   = {The Cross-Section of Expected Stock Returns},
  journal = {The Journal of Finance},
  year    = {1992},
  volume  = {47},
  number  = {2},
  pages   = {427-465},
}

@Comment{jabref-meta: databaseType:bibtex;}

When I compile, after having manually deleted all aux, bbl, and other files, it compiles (pdfLaTeX) great once, but the second time, I receive the error:

! Missing = inserted for \ifnum.
<to be read again> 
                   \def 
l.14 ...y not like this like this: \cite{Fama1992}
                                                   and \citep{Fama1992} and ...

From then on, the next compiling will go through without error, then this error again, etc.

However, the output is never satisfactory, because the in-text citations relating to the bib-file are always only question marks:

enter image description here

What I need is to include an external bibliography file (created with Jabref) with working in-text citations, as in the first sentence in the picture. (The only reason why I include the two entries manually and the bib-file at the same time here is to demonstrate the problem.)


What I played with is to replace sageh with sageapa in the class options, because I actually want to cite in APA style. But then I obtain the error:

! Undefined control sequence.
l.14 ...this like this: \cite{Fama1992} and \citep
                                                  {Fama1992} and \citet{Fama...

for seemingly every citing command that is not just plain cite. I noticed that the combination of sageh and \bibliographystyle{mslapa} is also in accordance with APA, so me having to use sageh like this is no further problem, but perhaps relevant to the first problem and its solution.

  • 1
    Where do your used class come from? uk.sagepub.com/sites/default/files/sage_latex_template_0.zip ? – Mensch Nov 30 '17 at 19:58
  • Yes, that's it! – Marie. P. Nov 30 '17 at 20:08
  • You seem to have both a manually generated thebibliography environment as well as one that's generated by BibTeX (stored in \jobname.bbl). Is this impression correct? If so, what are you trying to achieve? – Mico Nov 30 '17 at 20:24
  • @Mico, This was only to demonstrate the problem. The sample file comes with the manually added bibliography, but for practical reasons, I need to use Jabref, a bib-file, and the \bibliography{}-command – Marie. P. Nov 30 '17 at 20:31
1

If you want to use the mslapa style then you must load the class with the sageapa option -- this will load the mslapa.sty instead of natbib (which is not compatible with the bst). You then can't use \citep and \citet:

\documentclass[PCfour,sageapa,times,doublespace]{sagej}
% add doublespace for submitting for review
\usepackage{moreverb,url}

%\input{preambleOS}
\usepackage[colorlinks,bookmarksopen,bookmarksnumbered,citecolor=red,urlcolor=red]{hyperref}

\begin{document}

 but why not like this like this: \cite{Fama1992} and 


\bibliography{test}
\bibliographystyle{mslapa}

\end{document} 

enter image description here

  • The above code works, but no longer when I also want to use in-text citations. Both citet and citep are then undefined commands. However, I saw that in the specific journal that I want to submit to, in-text citations are very well acceptable, and I want to use them, too. – Marie. P. Dec 1 '17 at 7:09
  • 1
    Check the documentation of mslapa. It describes the cite commands it offers ctan.mirrors.hoobly.com/macros/latex/contrib/mslapa/mslapa.pdf. – Ulrike Fischer Dec 1 '17 at 8:45
  • Thank you. When I use the codes \cite, \shortcite, and \citeyear in my otherwise unchanged MWE, I notice that \citeyear only gives gives as output "(1992)", unlike in the documentation (p.1-2, cases 1-3) where it suggests that \citeyear would give "Fama & French (1992)". Can you help? – Marie. P. Dec 1 '17 at 11:54
  • the example file uses something like "blah blah in the work of Dosher and colleagues \citeyear{DOSH89A}" to get a \citet-look. I don't see after a short look an easy way to write a real cite command for this as the parentheses are always added by the internal \@cite. – Ulrike Fischer Dec 1 '17 at 12:15
  • Thank you! I will then try to figure out how to define a citation that refers to author and year, but only puts the year in parentheses, because doing that manually is not an option for my work. – Marie. P. Dec 1 '17 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.