0

I tried installing CULMUS following the instructions here: https://www.guyrutenberg.com/culmus-latex/

However, the last step always fails and I cannot render any Hebrew text.

I am using Mac OSX.

I ran the command:

sudo make CULMUSDIR=/Users/bjmongol/Documents/culmus-latex-0.7-r1 TEXMFDIR=/usr/local/texlive/texmf-local

and

sudo make install CULMUSDIR=/Users/bjmongol/Documents/culmus-latex-0.7-r1 TEXMFDIR=/usr/local/texlive/texmf-local

This is the log:

updmap-sys --enable Map=culmus.map
updmap [WARNING]: resetting $HOME value (was /Users/bjmongol) to root's actual home (/var/root).
updmap will read the following updmap.cfg files (in precedence order):
  /usr/local/texlive/2016/texmf-config/web2c/updmap.cfg
  /usr/local/texlive/2016/texmf-dist/web2c/updmap.cfg
updmap may write changes to the following updmap.cfg file:
  /usr/local/texlive/2016/texmf-config/web2c/updmap.cfg
/usr/local/texlive/2016/texmf-config/web2c/updmap.cfg unchanged.  Map files not recreated.
updmap: Updating ls-R files.

I'm not sure what this means. I made sure that I pointed to the right folders. I also tried doing sethebrew and unsethebrew when typing in TexShop. But it didn't work.

Any help would be greatly appreciated. Thank you

Update: when I try to render the following

\documentclass{article}
\usepackage{ucs}
\usepackage[utf8x]{inputenc}
\usepackage[english, hebrew]{babel}
\fontfamily{nachlieli}\selectfont 
\begin{document} 
מה קרה
\end{document}

these warnings show up:

Package babel Warning: No hyphenation patterns were preloaded for
(babel)                the language `Hebrew' into the format.
(babel)                Please, configure your TeX system to add them and
(babel)                rebuild the format. Now I will use the patterns
(babel)                preloaded for english instead on input line 57.

)) (/usr/local/texlive/2016/texmf-dist/tex/generic/babel-hebrew/he8enc.def)

LaTeX Font Warning: Font shape `OT1/nachlieli/m/n' undefined
(Font)              using `OT1/cmr/m/n' instead on input line 5.

(./latex_test.aux
(/usr/local/texlive/2016/texmf-dist/tex/generic/babel-hebrew/he8nachlieli.fd)

LaTeX Font Warning: Font shape `HE8/nachlieli/m/n' will be
(Font)              scaled to size 10.0pt on input line 2.

) (/usr/local/texlive/2016/texmf-dist/tex/generic/babel-hebrew/he8cmr.fd)
(/usr/local/texlive/2016/texmf-dist/tex/latex/ucs/ucsencs.def) [1{/usr/local/te
xlive/2016/texmf-var/fonts/map/pdftex/updmap/pdftex.map}] (./latex_test.aux)

LaTeX Font Warning: Some font shapes were not available, defaults substituted.

 ){/usr/local/texlive/texmf-local/fonts/enc/dvips/culmus/he8.enc}</usr/local/te
xlive/texmf-local/fonts/type1/public/culmus/DavidCLM-Medium.pfa>
Output written on latex_test.pdf (1 page, 8534 bytes).
SyncTeX written on latex_test.synctex.gz.
Transcript written on latex_test.log.

What does this mean?

  • On the website, it is explicitly tell that it work only for Linux, not Mac Os X. Why not just installing the oft/ttf font, and call them using \setmainfont? – Maïeul Dec 2 '17 at 20:11
  • Don't ever use sudo make. sudo make install is necessary if you don't follow upstream's non-privileged user advice. (Understandable as MacTeX doesn't.) But sudo make is just horrible. If that's in the instructions, the instructions are either written by an idiot or an act of idiocy by a non-idiot. Either way, they should be ignored.) This is general advice: sudo make should never be necessary and is always wrong. – cfr Dec 2 '17 at 21:45
  • Your value for CUMULUSDIR is wrong unless you really did install the fonts into the source directory of the LaTeX package. Do you have the fonts? You need them to build the support package. – cfr Dec 2 '17 at 21:55
  • @cfr I think you were right. I installed the required fonts into /usr/local/fonts/culmus but it still doesn't work. When I render in Latex it just shows up as a bunch of question marks. I've updated the question to show the log. – Taevanbat Mongol Dec 3 '17 at 18:13
  • 1
    Please update your question with the current commands and output. Is the map line added to the map file? Does the document look correct? What you're getting are only warnings. – cfr Dec 4 '17 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.