2

I am trying to pass a couple of options to xelatex from an Arara build-line:

% arara: xelatex: { shell: true, synctex: true, options: --output-driver="xdvipdfmx -q -E -V 7" }

But when running arara I get the following output in the texput.log

%&-line parsing enabled.
**'"--output-driver=xdvipdfmx -q -E -V 7"' beamer-example.tex

! Emergency stop.
<*> '"--output-driver=xdvipdfmx -q -E -V 7"' 
                                             beamer-example.tex
End of file on the terminal!

I suspect the problem to be with the whitespaces or the quotes, so I tried escaping the whitespaces using backslashes, exchanged the double quotes with single quotes and also tried leaving them out completely, but nothing worked so far.

On my system I can reproduce the behavior with the following file:

% arara: xelatex: { shell: true, synctex: true, options: --output-driver="xdvipdfmx -q -E -V 7" }
% arara: xelatex: { shell: true, synctex: true, options: --output-driver="xdvipdfmx -q -E -V 7" }
\documentclass[]{beamer}

\begin{document}
Nothing here
\end{document}

I just discovered arara, so I might be missing a simple or tiny thing.

Cheers!

  • I would add additional quotes but it works ok for me even without them. What is your tex system? And what is the content of the example file? – Ulrike Fischer Dec 3 '17 at 11:11
  • What version of arara are you using? I seem to remember that there was a problem with spaces in the past that's now been fixed. – Nicola Talbot Dec 3 '17 at 12:02
  • Thanks to both of you! I am currently using texlive version 2015.20160320-1 from the Ubuntu 16.04 with arara 3.0, but a system update is overdue anyways, so maybe that will help. Ulrike, what version of arara are you using? – Nodebody Dec 3 '17 at 21:06
  • The content of the file is a presentation that includes a couple of pages from an external pdf, that's what the output-driver is needed for, if I remember correctly, but I am able to reproduce the error with a simple file just containing the arara lines, documentclass and an empty document definition. – Nodebody Dec 3 '17 at 21:15
  • The system update is through, but the arara version is still the same. According to arara's github repository, it seems 3.0 is the latest version anyways. I will update the question with a sample document to reproduce the behavior. – Nodebody Dec 4 '17 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.