0

I need help with the code for changing the alignment of the footnoteline. In Hebrew, Yiddish and Arabic this line must start on the right and not on the left side of the page.

What I need: the footnoteline at the right or a centered or straight line without any alignment. I don't want any line in the Hebrew part on the left side (even with latin Text!)

I tried two thinks, that didn't work proper with my code. First (didn't change anything):

\renewcommand{\footnoteruleB}{\right@footnoterule}

Secondly (didn't change anything too):

\usepackage{bidi}\autofootnoterule

I am using multible footnotes: simple \footnote{} for Latin text and \RTLfootnote[]{} for Hebrew text with own numbers.

My example is a bit complex:

      % arara: xelatex

   \documentclass[10pt,a5paper,twoside]{scrbook}
   \usepackage[onehalfspacing]{setspace}

   \usepackage[bmargin=2.25cm]{geometry}



   \usepackage{scrpage2}
   \pagestyle{scrheadings}
   \clearscrheadfoot

   \ihead{\headmark}
   %\automark[chapter]{chapter}
   %\automark*[section]{}

   \ohead{\pagemark}
   \setheadsepline{0.4pt}
   \setkomafont{pageheadfoot}{\normalfont\normalcolor\small}\setkomafont{pagenumber}{\normalfont}

   %Formatierung der Kopfzeilen:
   \addtokomafont{pagehead}{\normalfont}


   \setkomafont{disposition}{\normalcolor\bfseries} %Schrift in Überschriften, Inhaltsverzeichnis

   \clubpenalty=10000
   \widowpenalty=10000

   \usepackage[parfill]{parskip}
   \usepackage[series={A,B,C}]{reledmac}
   \usepackage{reledpar}



   %%%\Xendnumberonlyfirstinline

   \Xendbeforepagenumber{S.\,}
   \Xendafterpagenumber{:\,}
   \Xendlineprefixsingle{Z.\,}

   \setgoalfraction{0.85}


   \lineation{section}
   \linenummargin{left}%%right für Zeilennummern rechts
   %\setRlineflag{}



   \linenumincrement*{5}
   \firstlinenum*{0} %Zahl hochsetzen, um Titelei unnummeriert zu haben

   \maxchunks{10000}

   \usepackage{color}
   \usepackage{multicol,multirow, bigdelim}%%times RAUS





   \usepackage{amsmath}
   \usepackage{fontspec}
   \usepackage{polyglossia, xunicode}
   \usepackage{libertine}
   \setmainfont[Ligatures=TeX]{Linux Libertine}%Linux Libertine O %%EzraSIL hat keine kursiva

   \setmainlanguage{german}
   \setotherlanguage{hebrew}
   \newfontfamily\hebrewfont[Script=Hebrew]{EzraSIL}



   \setmainlanguage{german}
   \setotherlanguage{hebrew}


   \newfontfamily\hebrewfont[Script=Hebrew]{Arial}



   \newcommand\einzugjid{\hangindent=5mm\hangafter=1}

   \newcommand\speaker[1]{\noindent{#1} \einzugjid
   }

   \newcommand\einzug{\hangindent=5mm\hangafter=1}

   \newcommand\speakerd[1]{\noindent
   {\textsc{#1}} \einzug
   }

   \usepackage[normalem]{ulem}




   \renewcommand{\thefootnoteA}{\fnsymbol{footnoteA}}




   \begin{document}



   \begin{pages}
   \begin{Leftside}
    \setRTL
    \beginnumbering

    \pstart {\RL{\speaker{יוקב.}
     מייא איהר לייט, מער זעללט נאך אַביסכה וואַרטע מיט דעם עססע איך ווילל ער\footnote{\LR{in der Handschrift unleserlich.}}שט
     דען שופט רופע לאָססע, דער זאָלל
    אַהך מיט עססע. האַלט אַביסכה אין! שמואל, רוהף אמויהל דען
    !\RTLfootnote[4]{\RL{זאָן ווירד געוואֶהנליך דורך שאַאף איבערזעטצט (נאַך מענדעלזאָהן: קליינעס פֿיה). שאַף איין
    י\~{{\RL{}}}ודיש-דייטשער
     מונדאַרט.
     שויף. אֶהנעלנד מיט שופט.
     דאַהער וואַהרשיינליך דיע אַנאַלאָגישע בענעננונג דער שולצען בייא דען לאנדיודען. זאָן. איים פלוראַל אַבער צאָננע. צאָננעכער נעננען זיע דען שאַאפֿהירטען.
    }}
    }} \pend
        \endnumbering
   \end{Leftside}


   \begin{Rightside}

   \beginnumbering


   \pstart BLA German text goes here…\footnote{Footnote in latin Text.} \pend

   \endnumbering

   \end{Rightside}
   \end{pages}
   \Pages



   \end{document}

I am thankful for every idea how to solve this.

  • 1
    The first step is to simplify the example and to make it compilable. Neither the bib nor glossaries nor all the page styles settings are relevant, and the right side \pend and a \pstart/\pend pair is missing. – Ulrike Fischer Dec 5 '17 at 9:37
  • OK, I hope they aren't relevant and not disturbing anything. – לאה פּאַסטעך Dec 5 '17 at 9:40
  • 3
    If the code doesn't compile one can't test it. And if it contains to much unneeded details it is difficult to see what matters. If you want help invest some time in a good minimal example. – Ulrike Fischer Dec 5 '17 at 9:42
  • now it should run without troubles. I am sorry, it is not that I am too lazy making a good small example – it's just that I don't know what I can exclude from my code and what not. – לאה פּאַסטעך Dec 5 '17 at 11:57
  • 1
    I fixed up your MWE, but you should certainly have a look at The DuckBoat -- News from TeX.SE: Asking effective questions. It'll help you get used to the site here. – A Gold Man Dec 5 '17 at 20:09
1

You can use the bidi command \autofootnoterule to set the automatic detection of where the rule should be. However, you should know that this works by checking the direction of the first note on the page. That would mean that if you want a German footnote on a Yiddish page, you would need to start it with \RTLfootnote rather than the normal \footnote command.

That means in the Hebrew section of your MWE, you should change that first \footnote to this:

\RTLfootnote{\LR{In English}}

using the RTL footnote command to move it to the proper side of the page, and the LR so that the text itself is typeset in the proper direction.

In terms of your other request, to have the footnoterule centered, that's also possible. Just define your \footnoterule as follows:

\def\footnoterule{%
\kern-3pt%spacing from standard LaTeX rule
\hbox to \textwidth{\hfill\hrulefill\hfill}%make a centered rule
\kern2.6pt%more spacing from standard rule
}
  • As I wrote, I tried \usepackage{bidi}\autofootnoterulebut it didn't work. – לאה פּאַסטעך Dec 6 '17 at 7:40
  • 1
    @AGoldMan I think you removed too much. The main problem is that the footnotes were used inside a reledpar environment with pages in two different languages. – Ulrike Fischer Dec 6 '17 at 9:25
  • @UlrikeFischer I tried it with the original question too, and this solution worked. She just needed to use RTLfootnote instead of normal for her first footnote there. – A Gold Man Dec 6 '17 at 14:01
  • @AGoldMan thank you for your work! But your example really didn't work for me – See, my point is not that I want the english/german footnotes aligned on the left; it is that I want the footnoteline (for every footnote) on the right side or (if possible) only a centered line. Last one would be optimal. – לאה פּאַסטעך Dec 6 '17 at 15:09
  • @לאהפּאַסטעך I'm sorry if it wasn't clear, but you should try to use \RTLfootnote for that first footnote in German. I did this on my computer and it made the footnoteline go to the right side. I would need version information if trying that specifically doesn't help you. I'll also post a version that centers the footnoteline sometime tomorrow (don't have time now) – A Gold Man Dec 6 '17 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.