0

I've found many questions regarding the same issue in Google, but without any working advise, so I'm asking again:

MikTex 2.9 portable for Windows (pdflatex) reports below warning and hyphenation doesn't work correctly (lots of lines in my document overflows and hyphenated words are usually splitted wrong due to invalid hyphenation settings based on default english patterns instead of czech):

   Package babel Warning: No hyphenation patterns were preloaded for
   (babel)                the language `Czech' into the format.
   (babel)                Please, configure your TeX system to add them and
   (babel)                rebuild the format. Now I will use the patterns
   (babel)                preloaded for \language=0 instead on input line 53.

Minimal working example:

   \documentclass[a4paper]{book}
   \usepackage[czech]{babel}
   \usepackage[utf8]{inputenc}
   \usepackage[T1]{fontenc}


   \begin{document}

   \chapter{Test chapter}
   \paragraph{Test paragraph}Test text.

   \end{document}

Commandline:

   %latexpath%\pdflatex.exe test.tex

Installed packages (I've installed more packages, but babel-czech + arabi shall contain full czech support and issue is reproducible also with only these):

   %MIKTEXDIR%\texmfs\install\miktex\bin\mpm.exe --verbose --repository=%PKGDIR%\ --install babel-czech
   %MIKTEXDIR%\texmfs\install\miktex\bin\mpm.exe --verbose --repository=%PKGDIR%\ --install arabi

Czech language is correctly enabled in GUI configurator after installation of babel-czech. Also other support of czech works fine (fonts, typography, ...) in my documents - only hyphenation doesn't work. Czech hyphenation patterns are contained in MikTex directory structure (hyph-cs.tex), so issue seems to be a misconfiguration, not missing package.

I use MikTex version 2.9.6210 (currently 6521 is available), but hyphenation is essential feature, so I don't expect that one year old distribution isn't able to perform it.

What I'm doing wrong? What else has to be installed to get czech hyphenation working? Or configuration shall be somehow updated after installing babel-czech using mpm.exe command? Maybe I need to add other \usepackage in my document?

  • Welcome to TeX.SE! Did you install the complete MiKTeX? With my complete, current version of MiKTeX I can compile your code without problems ... – Kurt Dec 5 '17 at 21:43
  • Open miktex settings and check in the language tab if czech is activated. If yes recreate the formats. – Ulrike Fischer Dec 5 '17 at 22:52
  • Thanks for the responses. I have installed just the official portable package (cca 200 MB archive, decompressed cca 630 MB) and then babel-czech and arabi packages. Do you guess which package could be missing? Czech is activated in language tab in GUI. How to recreate formats? I expect I have such misconfiguration issue, because czech hyphenation patterns are present in directory structure. – Jan D. Dec 6 '17 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.