2

I use biblatex with biber backend and alphabetic style. If I declare a shortauthor as described in the manual 2.3.3 Corporate Authors and Editors my bibliography sorting is incorrect. REA17 should be before Tec12... any Ideas? Thank You!

enter image description here

My MWE:

\documentclass{book}

\usepackage[utf8]{inputenc} 

\usepackage[
    backend     = biber,
    style       = alphabetic,
    sorting     = nyt,          %Sort by name, year, title.
    sortlocale  = auto,         %If german with babel use auto
    sortcites   = true,         %sort in \cite{}
    natbib      = false,        %loads \citet, \citep, \citealt and \citealp
    hyperref    = auto,
    backref     = false,        %List page numbers to references
    isbn        = false,
]{biblatex}
\addbibresource{example.bib}

\begin{document}

\cite{NASARadEff,LT2012TR}

\printbibliography[heading=bibintoc]

\end{document}

And the external bibfile:

@techreport{LT2012TR,
  title = {ELDRS Radiation Testing of the RH118W Op-Amp for Linear Technology},
  author = {Linear Technology},
  institution = {Radiation Assured Devices},
  year = {2012}
}
@online{NASARadEff,
  title={Radiation Effects and Analysis Home Page},
  author={{The Radiation Effects and Analysis Group (REAG)}},
  shortauthor={REAG},
  organization={{National Aeronautics and Space Administration (NASA)}},
  year={2017},
  url = "https://radhome.gsfc.nasa.gov/"
}
  • 1
    Well, you use sorting=nyt so the first sort criterion is "name", and "Linear..." comes before "The Radiation...". By your bibliography sorting being "incorrect" you mean that you expect it to be sorted by the entry's label? If so, you should use sorting = anyt. – gusbrs Dec 6 '17 at 15:39
  • gusbrs is absolutely right. With sorting=nyt the name part of sorting is by author and not shorthauthor. The suggested sorting = anyt is the default if you load style=alphabetic (but you overwrite the default with the explicit sorting=nyt). natbib = false, hyperref = auto, backref = false are all the default settings. – moewe Dec 6 '17 at 15:51
3

You use sorting=nyt so the first sort criterion is "name", and "Linear..." comes before "The Radiation...". Biblatex is only sorting according to the criteria you specified.

If you want your bibliography to be sorted by the entry's label, you should specify a sorting which takes that into account. E.g. sorting = anyt, which (as well remembered by moewe) is the alphabetic style's default, so you only need to remove sorting=nyt to achieve the desired results.

enter image description here

In full:

\documentclass{book}

\usepackage[utf8]{inputenc}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@techreport{LT2012TR,
    title = {ELDRS Radiation Testing of the RH118W Op-Amp for Linear Technology},
    author = {Linear Technology},
    institution = {Radiation Assured Devices},
    year = {2012}
}
@online{NASARadEff,
    title={Radiation Effects and Analysis Home Page},
    author={{The Radiation Effects and Analysis Group (REAG)}},
    shortauthor={REAG},
    organization={{National Aeronautics and Space Administration (NASA)}},
    year={2017},
    url = "https://radhome.gsfc.nasa.gov/"
}
\end{filecontents}

\usepackage[
    backend     = biber,
    style       = alphabetic,
    sortlocale  = auto,         %If german with babel use auto
    sortcites   = true,         %sort in \cite{}
    natbib      = false,        %loads \citet, \citep, \citealt and \citealp
    hyperref    = auto,
    backref     = false,        %List page numbers to references
    isbn        = false,
]{biblatex}
\addbibresource{\jobname.bib}

\begin{document}

\cite{NASARadEff,LT2012TR}

\printbibliography[heading=bibintoc]

\end{document}
  • 2
    Of course with style=alphabetic sorting = anyt, is already the default. – moewe Dec 6 '17 at 15:47
  • @moewe, thanks for pointing that out. Answer updated accordingly. – gusbrs Dec 6 '17 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.