0

I am writing a paper that needs to be formatted using the LNCS style, which is not available out of the box with LyX 2.2.3. How do I install it on my LyX install for Windows 10 x64?

2 Answers 2

2

The following worked for me. It's a hybrid of this online how-to and my older question on how to do this on Mac OS X

Step 0: Quit LyX

Step 1:

Download llncs2e.zip, which contains llncs.cls and llncsdoc.sty. I just googled for a download link and got mine from here

Step 2:

Copy those files to the folder ... \ MiKTeX 2.7 \ tex \ latex \ lncs, where ... \ MiKTeX 2.7 is the folder in which MiKTeX is installed. On some systems, copy to ... \ MiKTeX 2.7 \ texmf \ latex \ lncs. The lncs folder will probably need to be created.

Mine was in C:\Program Files (x86)\MiKTeX 2.9\tex\latex, where I had to create the lncs folder (which requires admin privilege escalation). I extracted llncs.cls and llncsdoc.sty to this folder.

Step 3:

Run "texhash" from the command line.

Open up cmd and run texhash. Very straightforward

Step 4:

Run MikTex Settings. Press "Refresh FNDB" under General. Then, possibly, "Update Formats".

It wasn't obvious to me where MikTeX Settings was. This other SX post showed me what to do. Just look for admin in the Start Menu's search bar and you'll see MikTeX Settings (Admin)

Step 5:

Open Lyx and select Tools -> Reconfigure

Very straighforward

Step 6:
You're done. Go do a happy dance or something

1
  • I had the same problem and I basically followed steps 1 to 6 proposed by inspectorG4dget above (thanks) but had to improvise because my installation doesn't make use of MiKTex but it is using TeXLive. Then, I just had to skip step 4 and everything is working so far.
    – madt
    Sep 2, 2020 at 18:46
1

I'm using MikTex 2.9 on Windows10 and I didn't get the MikTex Settings by searching for it in the start menu. Instead I found it in the MikTex Console - run as admin, go to "Tasks" on the menu bar and run "refresh file name database". Took me some time to realize FNDB stood for "file name database"...

The previous answer is a very good answer, and I still got stuck on step 4 - if I skipped step 4 the document class just wouldn't become available. I would like to put it here in case someone else stumbles across it. Sorry for not being able to add a comment, I don't have enough reputation here.

1
  • Your answer is valid as much has changed since the other answer was written Today you are correct Step 1) Find and Open MiKTeX-console 2) Navigate to Packages Find/Filter e.g. LLNCS in packages 3) Install using + 4) Use TASKS Refresh Filename Database 5) repeat the above as admin if you did the above as user
    – user170109
    Apr 12, 2019 at 20:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .