1

I want to use LaTeX on Ubuntu 16.04 and I have installed texlive2017, sublimeText3 and the sublime plugin: latexTools. But when I create a new file, use CtrlShiftB to select "Latex-pdfLatex" and then use CtrlB to build the file, it throws me an error which is :

/usr/local/texlive/2017/texmf-dist/tex/latex/ctex/fontset/ctex-fontset-fandol.def:109: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! [  }]

pdfTeX error: pdflatex (file cyberb65): Font cyberb65 at 723 not found
Check the TeX log file for more information

and here is my configuration in LatexTools.sublime.settings:

"linux" : {
// Path used when invoking tex & friends; MUST include $PATH
"texpath" : "$PATH:/usr/local/texlive/2017/bin/x86_64-linux",
// Command to invoke Python. Useful if you have Python installed in a
// non-standard location or want to use a particular version of python.
// Both Python2 and Python3 are supported, but must have the DBus bindings
// installed.
"python": "/usr/bin/Python3",
// The name of the ST2 or ST3 executable. On Ubuntu, both subl and sublime-text are
// available for ST2; adjust as needed for other platforms, and for ST3
"sublime": "sublime-text",
// How long to wait after evince or okular has launched before sending a sync message
// in seconds, floating point; choose 2.0 or 3.0 on a slower machine, 0.5 on a fast one
// Note: only tweak this if sync after launching the PDF viewer does not seem to work,
// or if the PDF viewer opens instantly and you don't want to wait.
// Default: 1.5 (works on my MBP4,1...)
"sync_wait": 0.5,
// Command to invoke Sublime Text. Used if the keep_focus toggle is true.
// If blank, "subl" or "sublime_text" will be used.
"sublime_executable": "",
// how long (in ms) to wait after the jump_to_pdf command completes
// before switching focus back to Sublime Text. This may need to be
// adjusted depending on your machine and configuration.
"keep_focus_delay": 0.5
},

In addition, when I use CtrlShiftB to set "Latex-XeLatex" and then build the file, it did not throw errors but there was no pdf file created.

I also installed dbus, but it seems that it did not work.

Does it mean I need to install some fonts? What should I do now to build the file and get a pdf file?

1

Oh, I have solved this problem by changing my first line from \documentclass[UTF8]{ctexart} to \documentclass{article}. It seems that the sublime throw the error because of lacking something to support Chinese characters.

  • 1
    None of those errors are sublime errors. Your latex installation is missing fonts. Exactly which latex did you install? Upstream or the Ubuntu one? – daleif Dec 10 '17 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.