2

My professor has specific tweaks he wants me to do, especially with the citations. However, in attempting to make those tweaks, it seems something broke in Ryan Aycock's old MLA style, if it was even working to begin with. The symptoms:

  • my footer is consistently too large, by about a half of an inch
  • the font size, set in the \documentclass options to 12pt, is not 12pt (1/6in or 4.233mm), it's 9pt (1/8", or 3.125mm).
  • There is space between two of the bibliography entries

Here is the example pdf, and a minimal working example:

sample document file, style file, sample bibliography, BBX File, CBX file

I have scoured the internet trying to figure this out, but the geometry docs are a bit confusing and at this point I just don't have time to keep trying to work this out. Any suggestions?

Edit: I was measuring my fonts incorrectly (didn't count descenders). The other issues remain.

  • The space between the bibliography entries is because your .bib item RightInTwo is of type misc which biblatex-mla doesn't recognize as a proper entry type. So you need to reclassify it (e.g. unpublished) and it will appear correctly in the bibliography. The style file is a mess. I would remove all margin/geometry related code from it entirely and just use \usepackage[margin=1in]{geometry}. In a package you should use \RequirePackage instead of \usepackage. Also you should use newtxtext instead of mathptmx. – Alan Munn Dec 10 '17 at 22:57
  • Also, your sample document has no footer information, so I assume you mean "header" in the first problem? – Alan Munn Dec 10 '17 at 23:11
  • I actually meant margin. The text halts more than an inch from the bottom. Thanks so much for the tips. I've tried to jump headlong into tex this semester, doing every project and paper in it, but I'm still very new and it's a complicated system to get used to. – Chris Carrigan Brolly Dec 11 '17 at 2:38
1

The style file you're using is really a bit of a mess. To make things easier to understand, I've included all of it in the test document. I've deleted all of the margins related code and replaced it with simply \usepackage[margin=1in]{geometry}. I've also replaced the mathptmx package with newtxtext for an up to date Times Roman font. If you also need math support, also load newtxmath.

If you want to fix the package, replace all the \usepackage commands with \RequirePackage. The hyperref package likes to be loaded after most other packages, so you should load it last in the package and load your package after any other document packages you load.

The bibliography problem is solved by changing the entry type of your RightInTwo entry from misc to something else. I used unpublished as an example.

% !TEX TS-program = pdflatexmk

\documentclass[12pt,letterpaper]{article}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{graphicx}

%\usepackage{my-mla-pkg}

%%%%% This is the code that is currently in the package %%%%
\usepackage{newtxtext}   % Times New Roman font
\pagestyle{headings}

\usepackage[margin=1in]{geometry}

\usepackage{setspace}    
\doublespacing

%
%   Last name and page number on every page
%
\usepackage{fancyhdr}
\fancypagestyle{norule}{ %
    \renewcommand{\headrulewidth}{0pt}
    \renewcommand{\footrulewidth}{0pt}
  }
  \fancyhf{}
\pagestyle{headings}
\pagestyle{norule}

\usepackage{url}

% Bibliography/Works Cited Settings
\usepackage[american]{babel}
\usepackage{csquotes, xpatch}
\usepackage[backend=biber,bibstyle=my-mla,citestyle=my-mla,annotation=true]{biblatex}

% Hyperref
\usepackage[bookmarksnumbered]{hyperref} % hyperref should be loaded last.

\setlength{\parindent}{0.5in}

%   MLA environment
\newenvironment{mla}[6]{ \setcounter{page}{1} \fancyhead[RO]{#2{}\thepage}
  \raggedright #1\ #2 \\
  Professor #3 \\
  #4 \\
  #5 \\
  \centering #6 \\
  \frenchspacing\raggedright\setlength{\parindent}{.5in}{ \nonfrenchspacing} }

%
%   Block quote environment
%
\newenvironment{blocks}{\begin{quote} \linespread{1} \small
    \normalsize}{\end{quote} \linespread{2} \small \normalsize}
\newenvironment{blockm}{\begin{quotation} \linespread{1} \small
    \normalsize}{\end{quotation} \linespread{2} \small \normalsize}

%  
%   Russ Ault's mla quote environment
%   
\newenvironment{mlaquote}{\list{}{\leftmargin=1in}\item[]}{\endlist}
\newenvironment{mlaquotation}{\list{}{\leftmargin=1in}\item[]\parindent=0.5in}{\endlist}

%%%% End of package code


\newcommand{\firstname}{m00n }
\newcommand{\lastname}{aspookyghosty }
\newcommand{\prof}{my english prof}
\newcommand{\class}{english class}

\DeclareFieldFormat{postnote}{#1}
\DeclareFieldFormat{multipostnote}{#1}
% enable annotations
\usepackage{blindtext}
\defbibheading{bibliography}{\centering Works Cited}
\author{\firstname \lastname}
\addbibresource{frankencrit-citations.bib}


\begin{document}
\begin{mla}{\firstname}{\lastname}{\prof}{\class}{\today}{MinimalWorkingExample}
  This is a minimal working example.
  \Blindtext
  \nocite{*}
  \newpage
  \printbibliography
\end{mla}
\end{document}

Acrobat image

bib fragment

  • Ok, this works much better. However, when I print it as you have, every margin is 1/4" larger than it should be. I figured it was from the text sizing stuff, so I hardcoded the paper and text sizes into the \require[opts]{geometry} call. Now my only problem is the bottom margin, which is still that 1/4" off. Again, thanks so much, that looks awesome – Chris Carrigan Brolly Dec 11 '17 at 2:52
  • 2
    @ChrisCarriganBrolly Your printing problem is likely because your PDF previewer is shrinking the page. The settings in the document give you exactly 1 inch margins (as the screenshot from Acrobat shows). Because you are using \doublespacing you will never get the bottom of the text to match the bottom margin. If you add \singlespacing to your test document you will see that the text lines up at exactly 1 inch/ – Alan Munn Dec 11 '17 at 2:57
  • I am not talking about my print preview, though. I am talking about an actually printed document. With \RequirePackage[paperheight=11in,paperwidth=8.5in,textwidth=6.5in,textheight=9in,margin=1in]{geometry} I get perfect printing, except for the bottom--but you've just cleared that up. Again, thanks so much for your help. – Chris Carrigan Brolly Dec 11 '17 at 3:05
  • 2
    @ChrisCarriganBrolly Yes, I understand, but many previewers have an option "Shrink page to fit" when printing, which can cause this behaviour. – Alan Munn Dec 11 '17 at 3:06
  • I'm not sure I understand what you mean? When I printed it without that line above the margins this is what I got, a full 1/8" off (I was wrong when I said 1/4", apologies). It's fixed now, so at this point it's just my curiosity left, you've been great. – Chris Carrigan Brolly Dec 11 '17 at 3:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.