1

I'm writing my thesis using the package arsclassica and the scrreprt document class provided by KOMA-Script.

arsclassica.sty in its implementation sets (line 14):

%************************************************************
% Text body
%************************************************************
\areaset[current]{370pt}{784pt}

Which tells the KOMA-Script to force that defined width-height text area p.44 of the KOMA bundle documentation scrguien.pdf.

I want to use my own dividing DIV as explained in par. 2.2 of the KOMA bundle documentation scrguien.pdffor the page layout but the following failed to set my own DIV:

\PassOptionsToPackage{DIV=15}{typearea}
\documentclass[12pt,a4paper,BCOR=5mm]{scrreprt}
\usepackage{arsclassica}
...

Nor worked

\documentclass[12pt,a4paper,BCOR=5mm]{scrreprt}
\usepackage[DIV=15]{typearea}
\usepackage{arsclassica}
...

Neither did

\documentclass[12pt,a4paper,BCOR=5mm,DIV=15]{scrreprt}
\usepackage{arsclassica}
...

I have no errors in the log and I can't understand how I can ignore that command that arsclassica impose or override it with my preference.

  • 1
    You have to use \KOMAoptions{DIV=15,BCOR=5mm} after loading package arsclassica or you can use: \AtBeginDocument{\KOMAoptions{DIV=15,BCOR=5mm}} – esdd Dec 13 '17 at 14:00
  • @esdd that worked like a charm. However I didn't understood to use use it that way from he KOMA documentation. Is there any paragraph I missed maybe? Thank you very much! P.S. If you want to post it as an aswerd to accept it do it. – Maxiride Dec 13 '17 at 14:10
  • 1
  • I tried \typerarea too without success (second attempt example in the post). But missed that section, thank you very much for pointing it out. There are so many pages and section that I must have gotten lost. – Maxiride Dec 13 '17 at 16:48
3

\areaset[current]{370pt}{784pt} uses package typearea to recalculate the page layout and the margins. So all previous settings of DIV will be overwritten by package arcsclassica.

If you want to use DIV=15 you have to recalculate the page layout after the changes which are done by package arsclassica. You can use

\typearea[5mm]{15}

explicitly or set the KOMA-options BCOR and DIV using \KOMAoptions

\KOMAoptions{BCOR=5mm,DIV=15}

when package arsclassica is already loaded.

\documentclass[12pt,a4paper,BCOR=5mm,DIV=15]{scrreprt}
\AfterPackage*{arsclassica}{\KOMAoptions{BCOR=5mm,DIV=15}}
\usepackage{arsclassica}

\usepackage{lipsum}
\usepackage{showframe}
\begin{document}
\lipsum
\end{document}

Note that arsclassica loads and uses packages like titlesec and tocloft which break some KOMA-Script features. You will get warnings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.