1

I have the same problem as described here: Pagebreak doesn't work with floats and longtabu

I tried the provided solution approach - but it does not work. I have created a new longtable.sty and copied it in the miktex install dir, replacing the old one, but it still does not work.

any help is highly appreciated.

EDIT: In my case i got first the table and then the figure (float)...sorry for that. I found a way to work around it by not putting the table in a \begin{table}...\end{table} environment but started right away with \begin{tabularx}...table now looks slightly different and it is not a nice solution but I unfortunately do not have time for more try and error.

12
  • Welcome to TeX.SX! You should never replace any files in the TeX distro installation. That said it would be better if you could specify what "does not work" is and post a MWE.
    – TeXnician
    Dec 17, 2017 at 15:05
  • Thank you very much for the answer. Same MWE applies from the linked topic. Problem: i apply his solution approach but i do not know where to place the edited longtable.sty file. in short, i apparently do not know how to patch a .sty file
    – leif
    Dec 17, 2017 at 15:23
  • Just do what is written in the answer: Copy the posted code into a file longtable.sty in the same directory as your TeX is.
    – TeXnician
    Dec 17, 2017 at 15:30
  • if by "TeX" you are referring to the directory where my tex-project is, that i am working on - i did exactly that...but it did not help.
    – leif
    Dec 17, 2017 at 15:35
  • 4
    I'm voting to close this question as off-topic because OP' edit stated the problem solved (and not clear what the original problem was) Mar 11, 2018 at 13:09

0

Browse other questions tagged .