4

I am trying to use Garamond font. How do I go about getting this font?

\documentclass[12pt,a4paper]{article}


\usepackage{setspace}

\usepackage{geometry}

\usepackage{etoolbox}


\singlespacing
\usepackage{varwidth}
\geometry{margin=1.5in}
\title{}
\date{}
\author{}



\begin{document}
\maketitle
\end{document}
  • 1
    Welcome! Do you want Garamond as default? Or do you want it just for the title for some reason? Probably your MWE should produce some characters in the output. Or do you want to use Garamond only for the page numbers? Single spacing is default - you don't need setspace for this. – cfr Dec 19 '17 at 2:04
  • Wow! Quick response! Awesome! Ummm...I want to use it as default...like...for everything...I am so bad at this LaTex thing...I am trying to get better, though! – peewee Dec 19 '17 at 2:08
  • No: I don't have it installed. I didn't know I had to install anything. – peewee Dec 19 '17 at 2:10
  • You may not need to. Are you using TeX, pdfTeX, XeTeX, LuaTeX, ConTeXt or something else to compile? If you are using an editor, this is probably set in the preferences. You can also look at the .log file to see what you're using. The first couple of lines tell you. – cfr Dec 19 '17 at 2:17
  • I am using (at least I think I am using) pdfTeX. Although the tab next to the "Typeset" button reads "LaTeX". So I am not certain whether I am using Tex or pdfTeX. – peewee Dec 19 '17 at 2:24
10

If you are using TeX or pdfTeX, you can load one of several packages to set your default document font to a Garamond. If you are using LuaTeX or XeTeX, you can choose from any font installed for your system.

Here are some options for the traditional engines. The LaTeX Font Catalogue can be used to find information about TeX fonts for these cases.

EB Garamond:

EB Garamond

This would be my preference.

garamondx:

garamondx

This is an extended version of EB Garamond which ignores the font's typographical context.

Cormorant Garamond:

Cormorant Garamond

This is a new package about which I know nothing.

In the code below, ebgaramond is enabled. The alternative lines for the other options above are commented. ebgaramond and CormorantGaramond are included in current TeX Live, but garamondx can't be. If you want to use this package, download the getnonfreefonts script and use it to install the package. Licensing means it cannot be included in the main distribution.

\documentclass[border=10pt]{standalone}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{ebgaramond}
% \usepackage{garamondx}
% \usepackage{CormorantGaramond}
\begin{document}
  The quick brown fox jumped over the lazy dog.
\end{document}
  • 1
    Can you perhaps explain the step of loading "one of several packages to set your default document font to a Garamond."? – peewee Dec 19 '17 at 2:28
  • 1
    OK: so I tried using the \usepackage{garamondx} and got the message that "garamondx.sty" is not found. – peewee Dec 19 '17 at 2:34
  • @peewee In the preamble, ebgaramond is loaded. The lines to load garamondx and CormorantGaramond are commented. If you want one of those two, comment the line for EB Garamond and uncomment the line you want. – cfr Dec 19 '17 at 2:35
  • @peewee Try either of the other two. garamondx is available using the getnonfreefonts script if you're using TeX Live, but the other two are part of the default distribution. – cfr Dec 19 '17 at 2:36
  • god I feel so stupid right now. I will get back to you in a bit---let me try to figure it out. Thanks for helping me. – peewee Dec 19 '17 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.