1

I can not fix the bug.

I hope someone may help me out.

Missing number, treated as zero. \catcode\string`@=
Missing number, treated as zero. \catcode`\.=
Missing number, treated as zero. \catcode`\p=
Missing number, treated as zero. \catcode`\t=
Use of \@ doesn't match its definition. \@@mptopdf@@newabove
Missing number, treated as zero. \catcode`\@=
Undefined control sequence. \unprotect
  • 6
    An example of code producing the issue? – egreg Dec 19 '17 at 11:18
  • 5
    Something in your preamble seems to change the catcode of the equal sign. Are you using \usepackage[turkish]{babel}? – Ulrike Fischer Dec 19 '17 at 11:25
  • Yes I use \usepackage[turkish]{babel} – Raio Dec 19 '17 at 11:27
  • 7
    I can reproduce the error. Looks like a bug to me. As a workaround load graphicx before babel. – Ulrike Fischer Dec 19 '17 at 11:28
  • 4
    The next update of graphics-def will contain code to prevent the clash between the catcode settings. Until then load graphicx as I already wrote before babel. – Ulrike Fischer Dec 19 '17 at 12:12
2

This is an incompability between graphicx and turkish:

\documentclass{report}
\usepackage[turkish]{babel}
\usepackage{graphicx}

\begin{document}
blub
\end{document}

turkish makes the equal sign active at begin document and this leads to error when later supp-pdf.mkii is read. The problem will be resolve in the next graphicx version. A work-around until then is to load graphicx before babel:

\documentclass{report}

\usepackage{graphicx}
\usepackage[turkish]{babel}
\begin{document}
blub
\end{document} 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.