3

The following MWE does not compile a proper bibliography using biblatex with either biber or bibtex backends in TeXstudio (version info below) - but only on Windows 10; none of the following give any errors on my Ubuntu boot:

\documentclass{article}
\usepackage[backend=bibtex]{biblatex} % also tried backend=biber
\bibliography{tmp}
\begin{filecontents}{tmp.bib}
  @Article{Ashburner2005,
    author   = {Ashburner, John and Friston, Karl J},
    title    = {{Unified segmentation.}},
    journal  = {NeuroImage},
    year     = {2005}
  }
\end{filecontents}
\begin{document}
  \cite{Ashburner2005}
  \printbibliography
\end{document}

The error messages I receive are

bibtex:

Process started: bibtex.exe "tmp"
I couldn't open file name `tmp.blg'
Process exited normally

biber:

Can't open tmp.blg (Permission denied) at C:\Users\Jesse\AppData\Local\Temp\par-4a65737365\cache-02947398048c143181ebb9c4e483433d2665ac35\inc\lib/Log/Log4perl/Appender/File.pm line 151.

and in both cases the PDF is the unformatted [Ashburner2005], nothing else.

Every time I compile, I clean all files except the .tex files from this directory. I've tried compiling from the command line and via TeXstudio.

Some other possibly useful info from the .log file

...
file 'biblatex-dm.cfg' not found.
...
Package biblatex Info: ... file 'tmp.bbl' not found.
...

This seems to be a recent issue. I haven't used Windows in a while ... I'm completely stumped. I suspect it is from a MikTeX update? Questions:

  1. Why is this behavior different with OS?

  2. Can you compile my MWE without issue?

  3. What is the problem / how can I fix it?

Seems to be related to this one.

Versions:

TeXstudio 2.12.6 (hg 6632:7777b2b8a906) Using Qt Version 5.9.1, compiled with Qt 5.9.1 R

MiKTeX-pdfTeX 2.9.6499 (1.40.18) (MiKTeX 2.9.6500 64-bit)

  • There seems to be a problem with permissions of your files. Have you checked that your Windows user has write access to them? And that the .blg file has been generated? – TeXnician Dec 20 '17 at 6:24
  • For (2) Yes, no problem. For (1): That my not be an OS, but a distro issue (I assume you do not use MikTeX on Linux, but TeX Live). – TeXnician Dec 20 '17 at 6:28
  • 1st comment: I made everything in the folder "not read only" under properties but I doubt this changed anything (there was read only git stuff in the original project), how could I check further? 2nd comment, thanks for testing. And yeah Tex live under Ubuntu, MikTex on Windows. Can you help direct me to info on reinstalling an older version of MikTex, if it comes to that? – Jesse Knight Dec 20 '17 at 7:04
  • My experience: Dual-booting with both OS I've installed TeX Live on Windows and it works with less conflicts, but maybe someone else has some ideas which are not aiming at reinstallation. – TeXnician Dec 20 '17 at 7:06
  • 1
    The other question is not related. There was only a version mismatch. You have a permission problem. Normally this means either that you are the wrong folder - but as the log can be created this is improbable here - or that some overeager security software is preventing the writing of the file. In which folder is your test file.? – Ulrike Fischer Dec 20 '17 at 7:59
5

Turns out Bitdefender was silently blocking biber.exe and bibtex.exe. What an obnoxious "feature".

Sorry for wasting everybody's time.

  • This is exactly what happened to me. A silent block from BitDefender. – ako Jul 20 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.