1

All my cites seems to be working, except this one, and I can't figure out why — like all of my bibliography, it's exported from Mendeley, so I don't understand it isn't working… and now I'm out of ideas, so I hope that someone can help me :)

The code with the cite is:

The data in the table are obtained from~\cite{John2008}.

The warning is:

LaTeX Warning: Citation 'John2008' on page 5 undefined on input line 8.

This is the entry:

@incollection{John2008,
author = {{John, O. P., Naumann, L. P. Soto}, C. J.},
booktitle = {Handbook of personality: Theory and research},
number = {Chapter 4},
pages = {114--158},
publisher = {New York, NY: Guilford Press},
title = {{Handbook of personality: Theory and research}},
url = {https://www.ocf.berkeley.edu/{~}johnlab/bigfive.htm},
year = {2008}
}

I tried to remove the tilde from the URL, but that didn't help.

I use Biber and the \printbibliography-command to print the bibliography.

  • 5
    You have too many commas in author name. It should be author = {John, O. P. and Naumann, L. P. and Soto, C. J.}, – Ulrike Fischer Dec 20 '17 at 23:18
  • 4
    take a look at the author field. at the very least the braces are peculiarly placed. – barbara beeton Dec 20 '17 at 23:18
5

In your code are several errors:

  1. authors are divided by and, not by a comma
  2. The braces in the author field are wrong, just delete the second pair
  3. delete the braces around ~ in the url

So with the following MWE

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@incollection{John2008,
  author    = {John, O. P. and Naumann, L. P. and Soto, C. J.},
  booktitle = {Handbook of personality: Theory and research},
  number    = {Chapter 4},
  pages     = {114--158},
  publisher = {New York, NY: Guilford Press},
  title     = {Handbook of personality: Theory and research},
  url       = {https://www.ocf.berkeley.edu/~johnlab/bigfive.htm},
  year      = {2008},
}
\end{filecontents*}


\documentclass{article}

\usepackage[%
  backend=biber,
  style=authortitle,
]{biblatex}
\addbibresource{\jobname.bib}


\begin{document}
The data in the table are obtained from~\cite{John2008}.
\printbibliography
\end{document}

you get the result without errors:

enter image description here

  • Thank you, I'm fairly new to bibtex/biblatex/biber! With your answer I also figured out how to fix the Mendeley export: The authors should be on separate lines in the author field, and not separated by a comma. By removing the tickmark in the Mendeley setting in "Bibtex" → "Escape LaTeX special characters (#{}%& etc.)" and using the fix in this Stackexchange answer, the URL are also formatted correctly. – AllanLRH Dec 21 '17 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.