4

In the following TeX file which is written based on elsarticle template, I want the second author (author2) be the corresponding author. I put the \corref instruction for author2 but when I run the code, the \ast symbol appears for both author2 and author3.

\documentclass[preprint,12pt]{elsarticle}
\usepackage{epsfig}
\usepackage{subcaption}
\captionsetup{compatibility=false}
%% The amssymb package provides various useful mathematical symbols
\usepackage{amssymb}
\usepackage{mathptmx} 
\usepackage{amsmath}
\newtheorem{thm}{Theorem}
\newproof{pf}{Proof}
\DeclareMathOperator*{\argmin}{arg\,min}
\DeclareMathOperator{\sign}{sign}
\journal{X}

\begin{document}

\begin{frontmatter}

\title{The title of the paper are placed here}


\author{author1}
\ead{author1\_ [email protected]}

\author{author2\corref{cor}}
\ead{[email protected]}

\author{author3}
\ead{[email protected]}

\address{The affiliations and adresses}
\cortext[cor]{Corresponding author}

\begin{abstract}
%% Text of abstract
Some text are presented here.
\end{abstract}

\begin{keyword}
%% keywords here, in the form: keyword \sep keyword
Keyword1 \sep Keyword2 \sep Keyword3

\end{keyword}

\end{frontmatter}

\section{Introduction}
\label{intro}
Introduction goes here.

\bibliographystyle{elsarticle-num} 
\bibliography{Bibiliography}
\end{document}

2 Answers 2

4

In my opinion, this is a bug in elsarticle. If you have three authors with the same address, you can work around the bug by an empty \corref statement.

\documentclass[preprint,12pt]{elsarticle}
\usepackage{amssymb}
\usepackage{amsmath}

\usepackage{graphicx}
\usepackage{subcaption}

\newtheorem{thm}{Theorem}
\newproof{pf}{Proof}
\DeclareMathOperator*{\argmin}{arg\,min}
\DeclareMathOperator{\sign}{sign}
\journal{X}

\begin{document}

\begin{frontmatter}

\title{The title of the paper are placed here}

\author{author1}
\ead{author1\[email protected]}

\author{author2\corref{cor}}
\ead{[email protected]}

\author{author3\corref{}}
\ead{[email protected]}

\address{The affiliations and addresses}

\cortext[cor]{Corresponding author}

\begin{abstract}
%% Text of abstract
Some text are presented here.
\end{abstract}

\begin{keyword}
%% keywords here, in the form: keyword \sep keyword
Keyword1 \sep Keyword2 \sep Keyword3

\end{keyword}

\end{frontmatter}

\section{Introduction}
\label{intro}
Introduction goes here.

\bibliographystyle{elsarticle-num} 
\bibliography{Bibiliography}
\end{document}

enter image description here

A few notes. The package epsfig only exists for compatibility with older (pre 1992) documents and should not be used in newer documents. The right package to use is graphicx. There's no reason for the compatibility=false option to caption. Instead of mathptmx you should consider

\usepackage{newtxtext,newtxmath}
1
  • If we want to put corresponding author between title and abstract, is it possible? Commented Aug 14, 2022 at 4:13
5

I don't know exactly the why, but I figured out the how.

The problem seems to be just the ordering of the commands and a better specification for the \address.

This should work:

\documentclass[preprint,12pt]{elsarticle}
\usepackage{epsfig}
\usepackage{subcaption}
\captionsetup{compatibility=false}
%% The amssymb package provides various useful mathematical symbols
\usepackage{amssymb}
\usepackage{mathptmx} 
\usepackage{amsmath}
\newtheorem{thm}{Theorem}
\newproof{pf}{Proof}
\DeclareMathOperator*{\argmin}{arg\,min}
\DeclareMathOperator{\sign}{sign}
\journal{X}

\begin{document}

\begin{frontmatter}

\title{The title of the paper are placed here}


\author[addr]{author1}
\address[addr]{The affiliations and adresses}
\ead{author1\_ [email protected]}

\author[addr]{author2\corref{cor}}
\cortext[cor]{Corresponding author}

\ead{[email protected]}

\author[addr]{author3}
\ead{[email protected]}

\begin{abstract}
%% Text of abstract
Some text are presented here.
\end{abstract}

\begin{keyword}
%% keywords here, in the form: keyword \sep keyword
Keyword1 \sep Keyword2 \sep Keyword3

\end{keyword}

\end{frontmatter}

\section{Introduction}
\label{intro}
Introduction goes here.

\bibliographystyle{elsarticle-num} 
\bibliography{Bibiliography}
\end{document}

The result is this:

enter image description here

What I modified was:

  1. I put the \cortext command right after the \corref. In your version the \cortext was after all the \authors.

  2. I added the optional argument to the \address, that gives sort of a tag to each address, and also moved the \address right after the first \author that has this address.

In case you need another address, just change the optional argument (between []) of the \author macro and add an \address entry, like this:

\author[addr]{author1}
\address[addr]{The affiliations and adresses}
\ead{author1\_ [email protected]}

\author[addr]{author2\corref{cor}}
\cortext[cor]{Corresponding author}

\ead{[email protected]}

\author[other]{author3}% <- Another address for this author
\address[other]{Another address}% <- The address right after the author
\ead{[email protected]}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .