2

I'm using TeXLive 2011. I had a lot of problems with compiling my large document yesterday and finally seemed to have gotten back to a working version, however now I get strange error messages in the list of figures like

[5 ./Diss.lof:61: Undefined control sequence. ...skip \abovedisplayskip \let \sml@listi =\leftmargin \leftmargini ... l.61 ...S.~391]{Johannaber2004}}}{49}{figure.2.10}

or

[5 ./Diss.lof:61: Undefined control sequence. ...skip \abovedisplayskip \let \sml@listi =\leftmargin \leftmargini ... l.61 ...te [S.~6ff]{Starke2004}}}{51}{figure.2.10}

The corresponding code in the lof file looks like that:

\contentsline {figure}{\numberline {\relax 2.10}{\ignorespaces Ursachen f\"ur Ma\IeC {\ss }abweichungen des Spritzgie\IeC {\ss }werkzeugs beim Kunststoffspritzguss nach~\textcite [S.~6ff]{Starke2004}}}{51}{figure.2.10}

I'm sorry, that at the moment I can not provide a minimal example, can someone explain, what this undefined control sequences are about? It seems to be a cite command in a caption.

EDIT

after Herbert's suggestion, I modified the source in the following way and removed all aux, lof, lot etc. files:

\caption[pure text without any command]{text with~\protect\textcite[][]{}}

But the problem persists:

[5 ! Undefined control sequence. ...skip \abovedisplayskip \let \sml@listi =\leftmargin \leftmargini ... l.61 ...te [S.~6ff]{Starke2004}}}{51}{figure.2.10}

I'm using the scrbook class (komascript). I'll try to set up a minimal example asap.

EDIT: a MWE

\documentclass{article}
\usepackage{biblatex}
\bibliography{biblatex-examples}
\begin{document}
\begin{figure}
  \caption[Bar \protect\textcite[][]{aksin}]{Foo \protect\textcite[][]{aksin}}
\end{figure}
\listoffigures
\end{document}

resulting in:

(./x.aux) (./x.bbl) (./x.lof
! Argument of \blx@citeargs@i has an extra }.
<inserted text> 
                \par 
l.2 ...line {1}{\ignorespaces Bar \textcite [}}{1}

?

where the lof file is this:

\defcounter {refsection}{0}\relax 
\contentsline {figure}{\numberline {1}{\ignorespaces Bar \textcite [}}{1}
\boolfalse {citerequest}\boolfalse {citetracker}\boolfalse {pagetracker}\boolfalse {backtracker}\relax 
1
  • 1
    I've gotten a similar issue when a caption uses commands that I've defined in another file. Getting rid of those fixed it. Oct 22, 2023 at 23:40

2 Answers 2

6

use \protect\textcite{} in your caption or better

\caption[entry for the lof without (!) \textcite]{... \protect\textcite{...} ...}

and delete the *.lof file for the next run otherwise you'll get always the same error again.

9
  • thank you. I'm just confused, because I've been using cite and citet and also citeauthor for a long time in captions without any problem (and without \protect). Is there any difference between them and \textcite (biblatex package)? Jan 11, 2012 at 11:31
  • the \protect does not solve the problem, see my edit Jan 11, 2012 at 11:43
  • yes, I deleted all auxiliary files before the next runs. The problem occurs in the 2nd pdflatex run. Jan 11, 2012 at 12:08
  • delete the cite command, delete all auxiliary files and run pdflatex twice. Did you get the error?
    – user2478
    Jan 11, 2012 at 12:11
  • 2
    That line cannot be the problem and there is no other way than creating a minimal example. Move the \end{document} up until the error is gone.
    – user2478
    Jan 11, 2012 at 13:19
0

after long testing, comparison of version history etc. I finally found that the error seemed to come from a completely different piece of code somewhere else (in the preamble, where I had not expected it):

I wanted to change the size of fixme´ annotations tosmall` and tried like that

\usepackage[draft, silent=true]{fixme}
\fxsetup{theme=color, inline, targetlayout=color, author=}
\newcommand{\N}[1]{\mbox{}\fxfatal*[inline=true,nomargin]{\small\sffamily/#1/}{}}

Apparently that led to mysterious problems like the one above.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .